Bug #90454

Don't break dashboard if widget is no longer available

Added by Daniel Siepmann 4 months ago. Updated 3 months ago.

Status:
Closed
Priority:
Should have
Category:
Dashboard
Target version:
Start date:
2020-02-20
Due date:
% Done:

0%

TYPO3 Version:
10
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

If a PHP Class for a widget does no longer exist, the whole dashboard breaks.
An example would be:

( ! ) Fatal error: Class 'TYPO3\CMS\Dashboard\Widgets\AbstractDoughnutChartWidget' not found in htdocs/typo3conf/ext/styleguide/Classes/Widgets/Pages.php on line 32

This widget extends the AbstractDoughnutChartWidget, which no longer exists, as I've removed the cherry picked patch. I guess the same behaviour would happen once an extension is removed from the system, which provided a widget that was added to a dashboard.

History

#1 Updated by Daniel Siepmann 4 months ago

  • Category set to Dashboard

#2 Updated by Daniel Siepmann 3 months ago

Looks like unavailable widget classes is already handled, but extending a no longer existing class is not. Not sure whether this can be handled, or whether we can ignore this situation.

The only situation I can imagine would be an extension providing further abstracts. But if another extension relies on that one, it should add the dependency. So I would vote to close this issue I guess.

#3 Updated by Georg Ringer 3 months ago

  • Target version set to 10 LTS

#4 Updated by Georg Ringer 3 months ago

  • Status changed from New to Closed

closed as requested

Also available in: Atom PDF