Bug #90532

LocalConfiguration filled with default extConf values after Upgrade

Added by Stefan Froemken 11 months ago. Updated 11 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Install Tool
Target version:
Start date:
2020-02-25
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
9
PHP Version:
7.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Hello,

I'm just upgrading a project from TYPO3 8 to TYPO3 9. After upgrading TYPO3s SourceCode I visit the TYPO3 Backend. But with this request the LocalConfiguration.php was updated silently. All my individual Configuration in extConf were thrown away and replaced with the default values of ext_conf_template.txt.
I mentioned this problem a little bit too late and started a new try to upgrade, but that time I visit the Installtool first. Now, the extConf values were transferred correctly into new EXTENSIONS key of LocalConfiguration.php.

Installtool calls "executeSilentLegacyExtConfExtensionConfigurationUpdateAction" which does the correct job.

First request to BE calls ExtensionConfiguration->synchronizeExtConfTemplateWithLocalConfigurationOfAllExtensions which creates EXTENSIONS key with default values. It seems that this line makes the problem:
$currentLocalConfiguration = $GLOBALS['TYPO3_CONF_VARS']['EXTENSIONS'] ?? [];

Stefan

#1

Updated by Stefan Froemken 11 months ago

  • Subject changed from LocalConfiguration filled with default extConf values to LocalConfiguration filled with default extConf values after Upgrade
#2

Updated by Susanne Moog 11 months ago

  • Status changed from New to Needs Feedback

The issue stems from not following the upgrade guide: When upgrading TYPO3, after switching the source, go to the install tool and follow the steps here https://docs.typo3.org/m/typo3/guide-installation/master/en-us/Upgrade/UseTheUpgradeWizard/Index.html - opening the backend before running upgrade wizards, database compare and silent upgraders might result in more weird behaviour otherwise (or a broken installation).

Can you confirm that the problem does not occur when following the upgrade guide?

#3

Updated by Stefan Froemken 11 months ago

Since TYPO3 9 the Installtool is part of the TYPO3 backend as module. So I work that way instead of install.php. Was a bad idea ;-)
As I have written: it works correct if I start the Upgrade over install.php.

#4

Updated by Stefan Froemken 11 months ago

  • Status changed from Needs Feedback to Closed

Also available in: Atom PDF