Project

General

Profile

Actions

Bug #90560

closed

Extbase class mapping : recordType not taken into account anymore

Added by Thomas BENLOLO over 4 years ago. Updated about 4 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Extbase
Target version:
Start date:
2020-02-27
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
10
PHP Version:
7.2
Tags:
Complexity:
no-brainer
Is Regression:
Yes
Sprint Focus:

Description

Since mapping is implemented in PHP file, recordType is not taken into account anymore.

The bug is located in \TYPO3\CMS\Extbase\Persistence\Generic\Mapper\DataMapFactory at line 141 :

$recordType = $classSettings['mapping']['recordType'];

should be :

$recordType = $classSettings['recordType'];
Actions #1

Updated by Gerrit Code Review over 4 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/63604

Actions #2

Updated by Christian Eßl over 4 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #3

Updated by Benni Mack about 4 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF