Feature #90567

Prevent saving of content element type "plugin" without Selected Plugin [list_type]

Added by Sybille Peters 3 months ago. Updated 3 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend User Interface
Target version:
-
Start date:
2020-02-28
Due date:
% Done:

0%

PHP Version:
Tags:
Complexity:
Sprint Focus:

Description

Create a content element of type plugin without plugin type selected, save and render the page.

Actual behavior

This results in an "Oops an error occured on page".

Error logs:

Wed, 26 Feb 2020 19:39:35 +0100 [ALERT] request="1852ca9cbf41f" component="TYPO3.CMS.Frontend.ContentObject.Exception.ProductionExceptionHandler": Oops, an error occurred! Code: 2020022619393396d9d52b - {"exception":"TYPO3Fluid\\Fluid\\Core\\ViewHelper\\Exception: No Content Object definition found at TypoScript object path \"tt_content.list.20.\" in

etc.

Actually this used to be less severe in versions before 9.x.

Expected behaviour

You cannot save until "plugin type" is selected.

Having a plugin without plugin type does not really make sense.


Related issues

Related to TYPO3 Core - Bug #88036: Adding a ce of type "plugin" without defining a plugin breaks FE Rejected 2019-03-29

History

#1 Updated by Georg Ringer 3 months ago

  • Status changed from New to Closed

closed as duplicate of #88036

actually there are many ways how this can be achieved so this can't be solved in the backend but FE must not fail

#2 Updated by Georg Ringer 3 months ago

  • Related to Bug #88036: Adding a ce of type "plugin" without defining a plugin breaks FE added

Also available in: Atom PDF