Bug #90642

Reload when changing fallBackType is not needed anymore

Added by Nikita Hovratov 3 months ago. Updated about 2 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Link Handling, Site Handling & Routing
Target version:
-
Start date:
2020-03-04
Due date:
% Done:

100%

TYPO3 Version:
10
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Before "Free mode" was introduced again, the fallbacks were only shown if "fallBackType" was set to "fallback" and thus the reload was needed. Now they are always shown, if the languageUid is > 0.

TCA for fallbackType and fallbacks

        'fallbackType' => [
            'label' => 'LLL:EXT:backend/Resources/Private/Language/locallang_siteconfiguration_tca.xlf:site_language.fallbackType',
            'displayCond' => 'FIELD:languageId:>:0',
--->        'onChange' => 'reload',
            'config' => [
                'type' => 'select',
                'renderType' => 'selectSingle',
                'items' => [
                    ['Strict: Show only translated content, based on overlays', 'strict'],
                    ['Fallback: Show default language if no translation exists', 'fallback'],
                    ['Free mode: Ignore translation and overlay concept, only show data from selected language', 'free'],
                ],
            ],
        ],
        'fallbacks' => [
            'label' => 'LLL:EXT:backend/Resources/Private/Language/locallang_siteconfiguration_tca.xlf:site_language.fallbacks',
--->        'displayCond' => 'FIELD:languageId:>:0',
            'config' => [
                'type' => 'select',
                'renderType' => 'selectMultipleSideBySide',
                'items' => [
                    ['Default Language', 0],
                ],
                'foreign_table' => 'sys_language',
                'size' => 5,
                'min' => 0,
            ],
        ],

Associated revisions

Revision d577b18f (diff)
Added by Christian Eßl 3 months ago

[BUGFIX] Remove unnecessary onChange="reload" in site language

Since "free mode" has been introduced in #86762 for site languages, the
previous onChange="reload" mechanism, when a fallbackType was changed,
is now unnecessary and is now removed.

Resolves: #90642
Relates: #86762
Releases: master, 9.5
Change-Id: I8bbf9a224dc47c14e4b4ec06961244b6903fbc69
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/63606
Tested-by: TYPO3com <>
Tested-by: Georg Ringer <>
Tested-by: Susanne Moog <>
Reviewed-by: Georg Ringer <>
Reviewed-by: Susanne Moog <>

Revision 7f050bac (diff)
Added by Christian Eßl 3 months ago

[BUGFIX] Remove unnecessary onChange="reload" in site language

Since "free mode" has been introduced in #86762 for site languages, the
previous onChange="reload" mechanism, when a fallbackType was changed,
is now unnecessary and is now removed.

Resolves: #90642
Relates: #86762
Releases: master, 9.5
Change-Id: I8bbf9a224dc47c14e4b4ec06961244b6903fbc69
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/63583
Tested-by: TYPO3com <>
Tested-by: Susanne Moog <>
Reviewed-by: Susanne Moog <>

History

#1 Updated by Gerrit Code Review 3 months ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/63606

#2 Updated by Gerrit Code Review 3 months ago

Patch set 1 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/63583

#3 Updated by Christian Eßl 3 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#4 Updated by Benni Mack about 2 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF