Project

General

Profile

Actions

Bug #90735

closed

PHP Parse error: syntax error, unexpected '?', expecting variable (T_VARIABLE) in typo3_src-9.5.14/typo3/sysext/core/Classes/Core/SystemEnvironmentBuilder.php on line 557

Added by Peter Murray almost 4 years ago. Updated almost 4 years ago.

Status:
Rejected
Priority:
Should have
Assignee:
-
Category:
CLI
Target version:
Start date:
2020-03-11
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
9
PHP Version:
7.0
Tags:
Complexity:
no-brainer
Is Regression:
Sprint Focus:

Description

protected static function isCliRequestType(?int $requestType): bool

should be

protected static function isCliRequestType(int $requestType): bool

Actions #1

Updated by Andreas Kienast almost 4 years ago

  • Status changed from New to Rejected

Thank you for your report.

TYPO3 9 LTS requires at least PHP 7.2, you reported you use PHP 7.0. Please update your PHP version accordingly.
Since this is no actual issue, I'll close this ticket.

Kind regards
Andreas

Actions

Also available in: Atom PDF