Bug #90828

Unable to edit page with form

Added by Edward A. Gabdullin over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Form Framework
Target version:
-
Start date:
2020-03-25
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
10
PHP Version:
7.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Good afternoon!
Unable to edit page with form

(1/1) TypeError

htmlspecialchars() expects parameter 1 to be string, null given
in /var/www/html/typo3_src-10.3.0/typo3/sysext/form/Classes/Hooks/FormPagePreviewRenderer.php line 63

        array &$row
    ) {
        if ($row['CType'] === 'form_formframework') {
            $contentType = $parentObject->CType_labels[$row['CType']];
            $itemContent .= $parentObject->linkEditContent('<strong>' . htmlspecialchars($contentType) . '</strong>', $row) . '<br />';

            $flexFormData = GeneralUtility::makeInstance(FlexFormService::class)
                ->convertFlexFormContentToArray($row['pi_flexform']);

Files

scr_599.jpg (275 KB) scr_599.jpg Edward A. Gabdullin, 2020-03-25 09:12
scr_600.jpg (379 KB) scr_600.jpg Edward A. Gabdullin, 2020-03-25 09:15

Related issues

Related to TYPO3 Core - Bug #90598: Initialize emulated PageLayoutView before calling hooksClosed2020-02-29

Actions
#1

Updated by Georg Ringer over 1 year ago

  • Status changed from New to Closed

thanks for creating the issue. this has been fixed with #90598.

I strongly suggest to use the current master for testing as a lot of stuff has been fixed as well.

#2

Updated by Georg Ringer over 1 year ago

  • Related to Bug #90598: Initialize emulated PageLayoutView before calling hooks added
#3

Updated by Edward A. Gabdullin over 1 year ago

Georg Ringer wrote:

thanks for creating the issue. this has been fixed with #90598.

I strongly suggest to use the current master for testing as a lot of stuff has been fixed as well.

I use Typo 10.3.0, the changes you specified are there. But the problem is also in stock!

#5

Updated by Riccardo De Contardi over 1 year ago

@Edward A. Gabdullin

maybe it is the same as #90863 ? can you try with the latest master?

#6

Updated by Edward A. Gabdullin over 1 year ago

I tried to connect the last master. The problem is gone.
Thanks!

Also available in: Atom PDF