Bug #90892

Re-enable dynamic resolving of view objects

Added by Alexander Schnitzler about 2 months ago. Updated about 1 month ago.

Status:
Closed
Priority:
Should have
Category:
Extbase
Target version:
Start date:
2020-03-30
Due date:
% Done:

100%

TYPO3 Version:
10
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Related issues

Related to TYPO3 Core - Bug #90788: Automatically use JsonView for json format Closed 2019-01-22 2019-01-22

Associated revisions

Revision 19dc7fa9 (diff)
Added by Alexander Schnitzler about 1 month ago

[BUGFIX] Re-enable dynamic resolving of view objects

With https://review.typo3.org/c/Packages/TYPO3.CMS/+/59514/ all
possibilities have been taken to define which view class to use
based on the current plugin environment parameters like controller
name, action name and format. Since this is used a lot in user land
code, this functionality has been re-enabled for version 10. But
still, the main flaw of the original code, i.e. checking for
possibly defined classes, is avoided. Instead, users can implement
a deterministic view resolver which ensures view objects that
implement the ViewInterface.

Releases: master
Resolves: #90892
Change-Id: Ide2919a6d86b2904087d3d7aa8dfece1abee4658
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/64017
Tested-by: Andreas Fernandez <>
Tested-by: TYPO3com <>
Tested-by: Daniel Goerz <>
Reviewed-by: Andreas Fernandez <>
Reviewed-by: Daniel Goerz <>

History

#1 Updated by Gerrit Code Review about 2 months ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/64017

#2 Updated by Alexander Schnitzler about 2 months ago

  • Related to Bug #90788: Automatically use JsonView for json format added

#3 Updated by Benni Mack about 1 month ago

  • Target version set to 10 LTS

#4 Updated by Gerrit Code Review about 1 month ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/64017

#5 Updated by Anonymous about 1 month ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#6 Updated by Benni Mack about 1 month ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF