Bug #90963

History throws error for logged in user when it contains a deleted page

Added by Patrick Broens 8 months ago. Updated 7 months ago.

Status:
Closed
Priority:
Must have
Category:
Backend API
Target version:
-
Start date:
2020-04-06
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
10
PHP Version:
7.3
Tags:
Complexity:
easy
Is Regression:
Sprint Focus:

Description

When a logged in backend user is entering the history/undo functionality for a certain page which contains a deleted page, the backend user authentication will throw the error "The given page record is invalid. Missing uid.", with code 1578950324.

This is due to the fact in RecordHistory only the deleted field is fetched to decide if a page has been deleted. If the page is deleted (field deleted === 1), it wants to copy the field pid - which has not been fetched, in the uid field of the deleted record. Since pid is null, the uid will also be null.

It will then try to calculate the page access on a record where the uid is null, which triggers the error.

#1

Updated by Gerrit Code Review 8 months ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/64088

#2

Updated by Gerrit Code Review 8 months ago

Patch set 1 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/63989

#3

Updated by Patrick Broens 8 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#4

Updated by Benni Mack 7 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF