Bug #91003

Spaces between adjacent hyperlinks in Regular Text Element content elements do not appear when the content is rendered

Added by Daniel Flaum about 2 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Fluid Styled Content
Target version:
-
Start date:
2020-04-12
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
9
PHP Version:
7.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

I've got some page content, and it contains two separate hyperlinks which are separated by a space. The space appears just fine in the backend rich text editor, but it disappears when the content is rendered on the frontend. The content element is a Regular Text Element provided by Typo3 core.

I have attached screenshots of how things appear in the backend and the frontend. The issue appears between the words "user" and "uses" towards the end of the English sentence.

Below can be found the content source code as it appears first in the backend rich text editor, and second in the browser. The issue reproduces consistently across different pages on my site, but I have not experimented beyond that, and won't do so unless other people are unable to reproduce.

Backend rich text editor source:

<p>An <strong>user purpose</strong> of a <a href="t3://page?uid=9">tool</a> is a <a href="t3://page?uid=14">purpose</a> for which an <a href="t3://page?uid=11">user</a> <a href="t3://page?uid=20">uses</a> the tool.</p>

Frontend rendered HTML:

<div id="c17" class="frame frame-default frame-type-text frame-layout-0"><p>An <strong>user purpose</strong> of a <a href="/field/documentary-field/tool">tool</a> is a <a href="/field/documentary-field/tool/purpose">purpose</a> for which an <a href="/field/documentary-field/tool/user">user</a><a href="/field/documentary-field/tool/usage">uses</a> the tool.</p></div>


Files

backend.png (20.5 KB) backend.png Daniel Flaum, 2020-04-12 00:49
frontend.png (17.8 KB) frontend.png Daniel Flaum, 2020-04-12 00:49

Related issues

Related to TYPO3 Core - Bug #86862: Using <f:spaceless> in layout for rendering any fluid_styled_content element causes valid RTE content to be be destroyed.ClosedBenjamin Kott2018-11-06

Actions
#1

Updated by Daniel Flaum about 2 years ago

I should add, the issue can be worked around with non-breaking spaces. This gets me what I want:

<a href="t3://page?uid=11">user</a>&nbsp;<a href="t3://page?uid=20">uses</a>

Except for that I do want things to break there if needed. But it's a small quibble for me.

#2

Updated by Riccardo De Contardi about 2 years ago

  • Status changed from New to Needs Feedback

On version 9.5, the file EXT:fluid_styled_content/Resources/Private/Layouts/Default.html still contains the <f:spaceless> viewhelper; try to remove it (use a different Layout)

#3

Updated by Daniel Flaum about 2 years ago

  • Category changed from Content Rendering to Fluid Styled Content
  • Assignee set to Riccardo De Contardi

That workaround does indeed work. Once I knew what file to look at, I found that this issue has been raised before in #86862, and has been resolved in later versions. Thanks Riccardo!

#4

Updated by Riccardo De Contardi about 2 years ago

  • Related to Bug #86862: Using <f:spaceless> in layout for rendering any fluid_styled_content element causes valid RTE content to be be destroyed. added
#5

Updated by Riccardo De Contardi about 2 years ago

  • Status changed from Needs Feedback to Closed
  • Assignee deleted (Riccardo De Contardi)

Thank you for your reply; I close this issue as already resolved on current Master.

Also available in: Atom PDF