Bug #91039

Reload filelist after file has been deleted fails

Added by Oliver Hader 3 months ago. Updated 3 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend API
Target version:
-
Start date:
2020-04-15
Due date:
% Done:

100%

TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Scenario

  • switch to clipboard mode (not using "normal" - see end of the filelist table)
  • set checkmark for one file in filelist
  • click on "copy" table header icon (putting it for "copy" mode to clipboard)
  • once the view has been released, click on "delete" table header icon (removing the element that is still on the clipboard)
  • confirm deletion dialog
  • exception
#1329647780 TYPO3\CMS\Core\Resource\Exception\ResourceDoesNotExistException
Object with identifier "1:/extension.png" does not exist in storage

Analysis

  • file has been deleted correctly
  • however since there's still a reference on the clipboard it fails when retrieving data for this (deleted) element

Related issues

Related to TYPO3 Core - Epic #90676: Clipboard related bugs and features Accepted 2020-03-07

Associated revisions

Revision df36be46 (diff)
Added by Oliver Hader 3 months ago

[BUGFIX] Reset clipboard state for files that have been deleted

Files that just have been deleted in filelist module need to be
removed from current clipboard state - otherwise the rendering
process will throw ResourceDoesNotExistException due to obviously
missing files.

Resolves: #91039
Releases: master, 9.5
Change-Id: Ic03cd8775ee4db40996e1152f4f0b1660323780f
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/64177
Tested-by: TYPO3com <>
Tested-by: Oliver Hader <>
Reviewed-by: Benni Mack <>
Reviewed-by: Markus Klein <>
Reviewed-by: Oliver Hader <>

Revision 024358c5 (diff)
Added by Oliver Hader 3 months ago

[BUGFIX] Reset clipboard state for files that have been deleted

Files that just have been deleted in filelist module need to be
removed from current clipboard state - otherwise the rendering
process will throw ResourceDoesNotExistException due to obviously
missing files.

Resolves: #91039
Releases: master, 9.5
Change-Id: Ic03cd8775ee4db40996e1152f4f0b1660323780f
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/64178
Tested-by: TYPO3com <>
Tested-by: Oliver Hader <>
Reviewed-by: Oliver Hader <>

History

#1 Updated by Oliver Hader 3 months ago

  • Related to Epic #90676: Clipboard related bugs and features added

#2 Updated by Gerrit Code Review 3 months ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/64177

#3 Updated by Gerrit Code Review 3 months ago

Patch set 1 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/64178

#4 Updated by Oliver Hader 3 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#5 Updated by Benni Mack 3 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF