Bug #91073

Install Tool: Check TCA action does not provide symfony container when loading ext_localconf files

Added by Benjamin Franzke 3 months ago. Updated 3 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Install Tool
Target version:
Start date:
2020-04-17
Due date:
% Done:

100%

TYPO3 Version:
10
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Using georgringer/news with commit 205cb3e "Check TCA" results in:

#1203699034 TYPO3\CMS\Core\Cache\Exception\NoSuchCacheException A cache with identifier "news" does not exist

The reason is that the cache is not available because the container has not been loaded which would add the cache per service configuration.


Related issues

Related to TYPO3 Core - Bug #89713: TCA check ignores PHP constants Closed 2019-11-19

Associated revisions

Revision d8dda294 (diff)
Added by Benjamin Franzke 3 months ago

[BUGFIX] Provide symfony container in install tool "Check TCA" action

A booted symfony container is needed as ext_localconf.php is
loaded since #89713 for the "Check TCA" action.
ext_localconf.php files may depend on a fully-booted
symfony container, therefore we need to provide it in this
case as well – or ext_localconf.php loading may fail.

Adapt the LateBootService to allow to reset to a
previously backuped container (even if it has been
reset in the meantime by another method).

Currently affected extensions were EXT:news before commit
ac0cb20c (which added a workaround for this case).
Thus the bugfix can be verified against the parent of that commit:
georgringer/news:205cb3e

Releases: master
Resolves: #91073
Related: #89713
Change-Id: Iaceb5efae26c1ae2e08e0db31ff2c223cc803ce7
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/64190
Tested-by: TYPO3com <>
Tested-by: Josef Glatz <>
Tested-by: Georg Ringer <>
Tested-by: Andreas Fernandez <>
Reviewed-by: Georg Ringer <>
Reviewed-by: Andreas Fernandez <>

History

#1 Updated by Benjamin Franzke 3 months ago

  • Related to Bug #89713: TCA check ignores PHP constants added

#2 Updated by Gerrit Code Review 3 months ago

  • Status changed from New to Under Review

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/64190

#3 Updated by Benjamin Franzke 3 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#4 Updated by Benni Mack 3 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF