Bug #91228

Custom Fluid Template for felogin

Added by Jonathan Starck over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
felogin
Target version:
-
Start date:
2020-04-28
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
10
PHP Version:
7.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Hi,

I wanted to create a custom Fluid Template for the felogin in my project and I was wondering that it didn't work.
That's how I started testing:

  1. I deactivated the Fluid Template to try the old version and adjusted the constant "styles.content.loginform.templateFile" to a old file.
    Result: I get the following error:
    ERROR: Content Element with uid "27" and type "felogin_login" has no rendering definition!
  2. I have activated the Fluid Template again and adjusted the constant "styles.content.loginform.templateFile" to a Fluid Template again. I added a line in to the template of /sysext/felogin/ to verify if my set file works.
    Result:
    styles.content.loginform.templateFile = 
    - EXT:myextension/path/Login.html
    - FILE:EXT:myextension/path/Login.html
    - fileadmin/Login.html
    - /fileadmin/Login.html
    - FILE:fileadmin/Login.html

    All variants do not work. only the file from "sysext/felogin/" is loaded.

It seems that the templating is currently not working or is not yet properly documented.


Related issues

Is duplicate of TYPO3 Core - Bug #90953: Add missing view path definition for feloginClosedKevin Appelt2020-04-05

Actions
#1

Updated by Jonathan Starck over 1 year ago

Maybe it's a duplicate of Bug #90953

#2

Updated by Jonathan Starck over 1 year ago

  • Is duplicate of Bug #90953: Add missing view path definition for felogin added
#3

Updated by Riccardo De Contardi over 1 year ago

  • Status changed from New to Closed

@Jonathan Starck thank you for your quick reply, I close your issue as a duplicate of #90953 - please continue the discussion there.

Thank you.

Also available in: Atom PDF