Project

General

Profile

Actions

Bug #91245

closed

foo/index.html leads to 404 since TYPO3 9.5.16

Added by Stephan Großberndt almost 4 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
-
Target version:
Start date:
2019-06-27
Due date:
2019-06-27
% Done:

0%

Estimated time:
TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

Using a configuration like

routeEnhancers:
  PageTypeSuffix:
    type: PageType
    default: '.html'
    map:
      '.html': 0

in TYPO3 <= 9.5.15 creates URLs like https://www.example.org/foo/bar.html but also allows access using https://www.example.org/foo/bar/index.html

With TYPO3 9.5.16 https://www.example.org/foo/bar/index.html returns HTTP 404


Related issues 2 (0 open2 closed)

Related to TYPO3 Core - Bug #91235: News Detail Page 404 after upgrade 9.5.16Closed2020-04-29

Actions
Follows TYPO3 Core - Bug #88633: Slugs ending with substring "index" result in an 404 errorClosed2019-06-26

Actions
Actions #1

Updated by Stephan Großberndt almost 4 years ago

  • Related to Bug #91235: News Detail Page 404 after upgrade 9.5.16 added
Actions #2

Updated by Benni Mack almost 4 years ago

  • Target version set to next-patchlevel
Actions #3

Updated by Stephan Großberndt almost 4 years ago

  • Related to Bug #91246: routeEnhancer defaults not applied in TYPO3 v9.5.16 added
Actions #5

Updated by Stephan Großberndt almost 4 years ago

  • Due date set to 2019-06-27
  • Start date changed from 2020-04-30 to 2019-06-27
  • Follows Bug #88633: Slugs ending with substring "index" result in an 404 error added
Actions #6

Updated by Benni Mack over 3 years ago

Yes. The reason was that if you have a page called "stock-index", then this would not be resolvable.

The solution (if you still want this behaviour, which was not expected) to be working you just need to modify your configuration like this:

routeEnhancers:
  PageTypeSuffix:
    type: PageType
    default: '.html'
    map:
      '.html': 0
      'index.html': 0
Actions #7

Updated by Benni Mack over 3 years ago

  • Status changed from New to Needs Feedback

Does this work for you?

Actions #8

Updated by Oliver Hader over 3 years ago

  • Related to deleted (Bug #91246: routeEnhancer defaults not applied in TYPO3 v9.5.16)
Actions #9

Updated by Stephan Großberndt over 3 years ago

  • Status changed from Needs Feedback to Closed

Yes, works for me. Thanks!

Actions

Also available in: Atom PDF