Project

General

Profile

Actions

Bug #91306

closed

Old cache configuration is not merged correctly

Added by Markus Klein about 4 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Must have
Assignee:
Category:
Caching
Target version:
-
Start date:
2020-05-05
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
10
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

#88366 introduced a new naming for caches and a fallback to handle old names transparently.
#88512 added another piece of code for this old-name schema handling

We have the situtation that an extension is changing the backend

An extension is changing the cache configuration of built-in caches in its ext_localconfig.php like this

$GLOBALS['TYPO3_CONF_VARS']['SYS']['caching']['cacheConfigurations']['cache_pages']['backend'] = \TYPO3\CMS\Core\Cache\Backend\RedisBackend::class;

According to documentation this should still work, but it does not.

While working with the site does cause any errors or log entries the flushing of the caches "does not happen" when editing content.
Example: Updating any content element on a page, does not flush the page's cache entry.

It turns out that the configuration of the caches is faulty, as the setting written above overwrites any existing setting of the cache, like the group.
This causes the experienced behaviour as DataHandler flushes caches by group.

The solution therefore must be to use old cache configurations (for caches starting with cache_*) as an additive override for existing cache configurations.
This way the basic settings from core are preserved.


Related issues 2 (0 open2 closed)

Related to TYPO3 Core - Task #88366: Streamline caching framework cachesClosedBenni Mack2019-05-15

Actions
Related to TYPO3 Core - Bug #88512: Flaws in accessing deprecated caches starting with "cache_"Closed2019-06-06

Actions
Actions #1

Updated by Markus Klein about 4 years ago

  • Related to Task #88366: Streamline caching framework caches added
Actions #2

Updated by Markus Klein about 4 years ago

  • Related to Bug #88512: Flaws in accessing deprecated caches starting with "cache_" added
Actions #3

Updated by Gerrit Code Review about 4 years ago

  • Status changed from Accepted to Under Review

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/64407

Actions #4

Updated by Gerrit Code Review about 4 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/64407

Actions #5

Updated by Gerrit Code Review about 4 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/64407

Actions #6

Updated by Gerrit Code Review about 4 years ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/64407

Actions #7

Updated by Markus Klein about 4 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #8

Updated by Benni Mack over 3 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF