Project

General

Profile

Actions

Bug #91380

closed

[FE][pageUnavailable_force] = true returns error code 500 instead of 503, skipping site handling

Added by Rolf Kiefhaber almost 4 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Link Handling, Site Handling & Routing
Target version:
Start date:
2020-05-13
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
10
PHP Version:
7.4
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

When setting the [FE][pageUnavailable_force] option to true, a default Typo3 error page is returned with a 500 error code header.
This happened with a freshly installed Typo3 10 with PHP 7.2, 7.3, or 7.4. Typo3 9 returned a 503 header as expected.

Setting this option also skips the site handling, so it is impossible to set a custom maintenance page, because the error is returned before site handling is executed. The default error page is returned even if a error handler for 0 is defined.
I don't know, if this is because of the 500 header or in addition to it.


Related issues 1 (0 open1 closed)

Related to TYPO3 Core - Bug #91722: Maintenance Mode skips/ignore Error HandlingClosed2020-06-29

Actions
Actions #1

Updated by Jonathan Starck over 3 years ago

  • Category set to Link Handling, Site Handling & Routing
  • Target version set to next-patchlevel
  • PHP Version set to 7.4

I can confirm the problem.
TYPO3 ignores the ErrorHandling on setting [FE][pageUnavailable_force].

Actions #3

Updated by Markus Klein over 3 years ago

  • Related to Bug #91722: Maintenance Mode skips/ignore Error Handling added
Actions #5

Updated by Oliver Bartsch over 2 years ago

  • Status changed from New to Needs Feedback

Hi, do you still encounter this bug?

I tested with latest matser and 10.4 - in both cases I correctly receive the 503 status code after setting pageUnavailable_force => true.

Actions #6

Updated by Rolf Kiefhaber over 2 years ago

I just tested on Typo3 10.4.21 and I get the 503 Maintenance Page now. Seems like on of the patch versions fixed it.

Actions #7

Updated by Oliver Bartsch over 2 years ago

  • Status changed from Needs Feedback to Closed

Hi, thanks for the feedback. Therefore, I close this issue now. In case you encounter this issue again, please create a new issue with reference to this one.

Actions

Also available in: Atom PDF