Bug #91636

Hidden fieds are not rendered any more, when no other field is present in a tab

Added by Helmut Hummel 22 days ago. Updated 20 days ago.

Status:
Under Review
Priority:
Should have
Assignee:
-
Category:
FormEngine aka TCEforms
Target version:
-
Start date:
2020-06-11
Due date:
% Done:

0%

TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

With #89094 tabs that are empty are not rendered any more.
This is fine, however other things like hidden fields or assets that are provided
by a child element are skipped as well, which leads to the situation that
e.g. when a tab only contains hidden fields, these will not be rendered any more.


Related issues

Related to TYPO3 Core - Bug #89094: Active tab could not be determined after disabling some tabs via TCEFORM Closed 2019-09-05

History

#1 Updated by Helmut Hummel 22 days ago

  • Related to Bug #89094: Active tab could not be determined after disabling some tabs via TCEFORM added

#2 Updated by Helmut Hummel 22 days ago

  • Is Regression set to Yes

#3 Updated by Gerrit Code Review 21 days ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/64874

#4 Updated by Helmut Hummel 21 days ago

  • Category set to FormEngine aka TCEforms

#5 Updated by Helmut Hummel 21 days ago

To reproduce, set all elements of the "Language" pallette (sys_language_uid, l10n_parent...) to "type": "input" and "renderType": "hidden"

expected: hidden fields are rendered
actual: hidden fields are not rendered

#6 Updated by Gerrit Code Review 20 days ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/64874

Also available in: Atom PDF