Bug #91700

Workspaces and SiteFinder aren't good friends

Added by Ingo Fabbri 18 days ago. Updated 17 days ago.

Status:
New
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2020-06-23
Due date:
% Done:

0%

TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Configure a rootpage uid 1.

Add a siteconfiguration for it.

Enable ext:workspaces

create a workspace

switch to the created workspace

edit/go-to the page-properties of the rootpage uid 1.

change some page-property values

save and close. cough I mean: close and click save in the dialog-modal.

once again edit page-properties of the rootpage uid 1.

WHOOOOOPS - looks like something went wrong!

No site found in root line of page 2

in /var/www/html/private/typo3/sysext/core/Classes/Site/SiteFinder.php line 138
            if (isset($this->mappingRootPageIdToIdentifier[(int)$pageInRootLine['uid']])) {
                return $this->sites[$this->mappingRootPageIdToIdentifier[(int)$pageInRootLine['uid']]];
            }
        }
        throw new SiteNotFoundException('No site found in root line of page ' . $pageId, 1521716622);
    }

    /**
     * @param bool $useCache

This is happening in TYPO3 v9. I guess this is still the case in v10 too.

History

#1 Updated by Ingo Fabbri 18 days ago

TYPO3 9.5.19

#2 Updated by Ingo Fabbri 18 days ago

  • Description updated (diff)

#3 Updated by Ingo Fabbri 18 days ago

  • Description updated (diff)

#4 Updated by Riccardo De Contardi 17 days ago

@Ingo Fabbri

I tried with both 9.5.19 and 11.0.0-dev the following steps

1) Click on Home page (ID=1) is a root page, with a site config defined for it
2) Workspace -> switch to configured "Draft" workspace (the workspace has a DB Mount on page ID=1)
3) Edit the page
4) Changed Subtitle and SEO Title
5) Save and close
6) Edit the page again

Result: no error

Is a different procedure needed?

Also available in: Atom PDF