Project

General

Profile

Actions

Bug #91823

closed

1.0 Priority in SEO gives an error

Added by Tomas Norre Mikkelsen over 3 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
SEO
Target version:
Start date:
2020-07-17
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
10
PHP Version:
7.4
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

When using the "typo3/cms-seo":"10.4.5" I get an error when selecting 1.0 as sitemap_priority.

Steps to reproduce

1. Edit a page
2. Go to SEO tab
3. Set sitemap_priority to 1.0
4. Press save
5. Follow error is shown in the flash message: 2: SQL error: 'Out of range value for column 'sitemap_priority' at row 1' (pages:1)

All the other values are working but the 1.0 isn't.

I'm not sure how the fix should look like, but should not be something to complex to fix.


Related issues 1 (0 open1 closed)

Related to TYPO3 Core - Bug #91736: Saving sitemap priority of 1.0 fails with MariaDBClosed2020-07-02

Actions
Actions #1

Updated by Tomas Norre Mikkelsen over 3 years ago

I'm on MariaDB

mysql Ver 15.1 Distrib 10.3.22-MariaDB, for debian-linux-gnu (x86_64) using readline 5.2

if this is of importance regarding SQL syntax.

Actions #2

Updated by Tomas Norre Mikkelsen over 3 years ago

From this stackoverflow it looks like it should be DICIMAL instead of DICIMAL in the ext_tables.sql
https://stackoverflow.com/questions/50781420/what-is-the-correct-default-value-for-a-mysql-decimal-field

Actions #3

Updated by Gerrit Code Review over 3 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/65057

Actions #4

Updated by Gerrit Code Review over 3 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/65057

Actions #5

Updated by Benni Mack over 3 years ago

  • Related to Bug #91736: Saving sitemap priority of 1.0 fails with MariaDB added
Actions #6

Updated by Georg Ringer over 3 years ago

  • Status changed from Under Review to Closed

closed in favor of #91736

Actions

Also available in: Atom PDF