Project

General

Profile

Actions

Bug #91975

closed

l10n_mode and l10n_display has no effect in categories

Added by Christian Toffolo almost 4 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Backend User Interface
Target version:
Start date:
2020-08-11
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
9
PHP Version:
7.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

I have TCA configured in this way:

but in BE, editing the localized record still displays the categories field and if modified the changes are saved in the DB.

Actions #1

Updated by Oliver Bartsch over 2 years ago

  • Status changed from New to Needs Feedback

Hi, I checked this in both, latest master and v10, but I'm not able to reproduce this anymore. After setting l10n_mode => 'exclude', the categories field is no longer shown in a translation.

Could you please check, if this issue still exists for you?

Actions #2

Updated by Christian Toffolo over 2 years ago

Hi Oliver!
I tested again this issue in TYPO3 10 LTS.
The category field is still visible in translated records.
But now, if the category field is edited in a translated record, the edits aren't saved in the DB.

Still, would be optimal if the field is hidden.

Actions #3

Updated by Christian Toffolo over 2 years ago

  • Status changed from Needs Feedback to Closed

Nevermind, I just found that removing the l10n_display option in TCA of categories field also made the field disappear from the translated record.
So this problem is no longer present. I close this.

Actions

Also available in: Atom PDF