Bug #92589

Workspace data integrity and reference index fixes

Added by Christian Kuhn 9 days ago. Updated 8 days ago.

Status:
Resolved
Priority:
Should have
Assignee:
-
Category:
Workspaces
Target version:
-
Start date:
2020-10-18
Due date:
% Done:

100%

TYPO3 Version:
10
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Related issues

Related to TYPO3 Core - Task #92467: Assert clean reference index after DataHandler tests Resolved 2020-10-01

Associated revisions

Revision b02172f3 (diff)
Added by Christian Kuhn 8 days ago

[BUGFIX] Workspace and reference index fixes

This drops all left over calls that suppress the refindex
integrity checks in DataHandler functional tests, except those
within ManyToMany tests: This area needs more work before the
reference index can be fixed.

Two bugs indirectly related to the reference index are fixed
along the way, those can't be separated as standalone patches:

  • When a translated page is deleted in workspaces, the
    DataHandler deleted live records on this page, too. This
    is fixed by adding a proper db restriction. This also
    fixes the reference index state in this scenario.
  • When publishing a delete placeholder that has inline children,
    workspace delete placeholders are created for the children, which
    is wrong. This happens because the user is not set to the live
    workspace during the publish operation. Temporarily changing the
    user workspace to live not only fixes the reference index, but
    does not create the bogus inline children placeholder records
    anymore, too.

Change-Id: I897f6a93b1d5a579bfa5c52e93e65119a018e4aa
Resolves: #92589
Related: #92467
Releases: master, 10.4
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/66152
Tested-by: TYPO3com <>
Tested-by: Benni Mack <>
Tested-by: Anja Leichsenring <>
Tested-by: Christian Kuhn <>
Reviewed-by: Benni Mack <>
Reviewed-by: David Steeb <>
Reviewed-by: Anja Leichsenring <>
Reviewed-by: Christian Kuhn <>

Revision cd94f3dd (diff)
Added by Christian Kuhn 8 days ago

[BUGFIX] Workspace and reference index fixes

This drops all left over calls that suppress the refindex
integrity checks in DataHandler functional tests, except those
within ManyToMany tests: This area needs more work before the
reference index can be fixed.

Two bugs indirectly related to the reference index are fixed
along the way, those can't be separated as standalone patches:

  • When a translated page is deleted in workspaces, the
    DataHandler deleted live records on this page, too. This
    is fixed by adding a proper db restriction. This also
    fixes the reference index state in this scenario.
  • When publishing a delete placeholder that has inline children,
    workspace delete placeholders are created for the children, which
    is wrong. This happens because the user is not set to the live
    workspace during the publish operation. Temporarily changing the
    user workspace to live not only fixes the reference index, but
    does not create the bogus inline children placeholder records
    anymore, too.

Change-Id: I897f6a93b1d5a579bfa5c52e93e65119a018e4aa
Resolves: #92589
Related: #92467
Releases: master, 10.4
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/66168
Tested-by: TYPO3com <>
Tested-by: Christian Kuhn <>
Reviewed-by: Christian Kuhn <>

History

#1 Updated by Christian Kuhn 9 days ago

  • Related to Task #92467: Assert clean reference index after DataHandler tests added

#2 Updated by Gerrit Code Review 9 days ago

  • Status changed from New to Under Review

Patch set 10 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/66152

#3 Updated by Gerrit Code Review 9 days ago

Patch set 1 for branch 10.4 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/66168

#4 Updated by Gerrit Code Review 8 days ago

Patch set 2 for branch 10.4 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/66168

#5 Updated by Gerrit Code Review 8 days ago

Patch set 3 for branch 10.4 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/66168

#6 Updated by Christian Kuhn 8 days ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF