Bug #92733

rebuildSlugsForSlugChange fails when changing slug of a localized root page

Added by Oliver Bartsch 29 days ago. Updated 28 days ago.

Status:
Resolved
Priority:
Should have
Category:
Link Handling, Site Handling & Routing
Target version:
-
Start date:
2020-10-29
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
10
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Changing a slug of a site with L>0 and pid=0 throws a SiteNotFoundException on save.

That's because rebuildSlugsForSlugChange calls SiteFinder::getSiteByPageId() with the pageId of the localized page. This page however has pid=0 set.

Therefore, it's not possible find any site configuration, because they are always mapped to the uid of the default page which we can not determine in this case.

Reproduce: Change the slug field of a localized root page in the page properties and try to save the page record.

#1

Updated by Oliver Bartsch 29 days ago

  • Subject changed from rebuildSlugsForSlugChange fails when changing slug of a localized site root to rebuildSlugsForSlugChange fails when changing slug of a localized root page
#2

Updated by Gerrit Code Review 29 days ago

  • Status changed from New to Under Review

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/66353

#3

Updated by Gerrit Code Review 29 days ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/66353

#4

Updated by Gerrit Code Review 28 days ago

Patch set 1 for branch 10.4 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/66341

#5

Updated by Oliver Bartsch 28 days ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF