Bug #93111

RuntimeException since ResetPasswordCommand does not set applicationType on faking a request object

Added by Oliver Bartsch 8 months ago. Updated 7 months ago.

Status:
Closed
Priority:
Should have
Category:
CLI
Target version:
Start date:
2020-12-18
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
11
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

The reset password command uses the method createFakeWebRequest to create a PSR-7. Since FluidEmail uses TSFE, TSFE:::getGlobalInstance() is called from the service container. This method however checks since #92953 for the application type. Since the application type is not set on faking the request, this fails and leads to: 'No valid attribute "applicationType" found in request object.'


Related issues

Related to TYPO3 Core - Task #92953: Drop usages of TYPO3_MODE and TYPO3_REQUESTTYPEClosed2020-11-30

Actions
Related to TYPO3 Core - Task #92951: Add application type to requestClosed2020-11-29

Actions
#1

Updated by Oliver Bartsch 8 months ago

  • Related to Task #92953: Drop usages of TYPO3_MODE and TYPO3_REQUESTTYPE added
#2

Updated by Oliver Bartsch 8 months ago

  • Related to Task #92951: Add application type to request added
#3

Updated by Gerrit Code Review 8 months ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/67186

#4

Updated by Oliver Bartsch 8 months ago

  • Subject changed from Reset password command does not set applicationType on faking a request object to RuntimeException since ResetPasswordCommand does not set applicationType on faking a request object
  • Status changed from Under Review to New
#5

Updated by Oliver Bartsch 8 months ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 100
#6

Updated by Benni Mack 7 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF