Bug #93141

rte_ckeditor does not display horizontal rule but the encoded <p>&lt;hr /&gt; </p>

Added by Joe Jones 2 months ago. Updated about 1 month ago.

Status:
New
Priority:
Should have
Assignee:
-
Category:
RTE (rtehtmlarea + ckeditor)
Target version:
Start date:
2020-12-21
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
10
PHP Version:
7.4
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Dear TYPO3-Team,
I tried using the HorizontalRule and removed the entry HorizontalRule from the "removeButtons"-List. I got the Button to insert a HR and the preview in the editor showed an hr. But in the frontend, TYPO3 renders

<p>&lt;hr /&gt; </p>

I could not find. where to change this. Also I tried the same in different installations. All the same. This should be work out of the box, shouldn't it?

Thanks for have a look.
Bye and merry christmas
Martin

#1

Updated by Oliver Bartsch 2 months ago

  • Subject changed from rte_ckeditor dows not display horizontal Rule but encodes <p>&lt;hr /&gt; </p> to rte_ckeditor does not display horizontal rule but the encoded <p>&lt;hr /&gt; </p>
#2

Updated by Riccardo De Contardi 2 months ago

Joe Jones I guess you are using a customized RTE yaml file; on the three files shipped with TYPO3 (default.yaml, miminal.yaml, full.yaml) I have not found the horizontal rule listed on the removeButtons session; instead it is in the insert toolbargroup.

I was able to insert it with adding the toolbargroup "Insert" in this way:

editor:
  config:
    toolbarGroups:
      - { name: insert, groups: [ insert ] } 

Could you post your yaml config file?

Could you also check that hr is listed as an allowed tag inside the lists lib.parseFunc and lib.parseFunc_RTE ?

#3

Updated by Joe Jones about 2 months ago

Hallo Riccardo,

sorry, that I answer that late. I got no notification from forge.typo3.org. Anyway, you rest my life. I work with TYPO3 for nearly 20 years, but I did not know enough about parseFunc_RTE. In deed, hr is not listed by default.

For all who needs the detailed solution:

lib {
    parseFunc_RTE {
        allowTags := addToList (hr)
    }
}

Now it works and I have to note it for the next time :-)

Thank you
Martin

#4

Updated by Riccardo De Contardi about 1 month ago

I am glad you solved your issue;

Maybe some extension or some Typoscript code removed it; I am looking at (just relevant lines)

/typo3/sysext/fluid_styled_content/Configuration/TypoScript/Helper/ParseFunc.typoscript

lib.parseFunc {
   allowTags = {$styles.content.allowTags}
}

/typo3/sysext/fluid_styled_content/Configuration/TypoScript/constants.typoscript

styles.content{
    allowTags= = a, abbr, acronym, address, article, aside, b, bdo, big, blockquote, br, caption, center, cite, code, col, colgroup, dd, del, dfn, dl, div, dt, em, font, footer, header, h1, h2, h3, h4, h5, h6, hr, i, img, ins, kbd, label, li, link, meta, nav, ol, p, pre, q, s, samp, sdfield, section, small, span, strike, strong, style, sub, sup, table, thead, tbody, tfoot, td, th, tr, title, tt, u, ul, var
}

this is for both TYPO3 10 and 11

May I close this issue? Thank you.

Also available in: Atom PDF