Project

General

Profile

Actions

Bug #93191

closed

FormEngine validation is broken with selectMultipleSideBySide

Added by Andreas Kienast about 3 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Should have
Category:
FormEngine aka TCEforms
Target version:
Start date:
2020-12-31
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
11
PHP Version:
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

If validators are enabled for selectMultipleSideBySide fields, the validators have no effect as the opposite field is checked instead.


Related issues 2 (0 open2 closed)

Related to TYPO3 Core - Task #87324: Split FormEngine.js into smaller chunksClosedAndreas Kienast2019-01-03

Actions
Is duplicate of TYPO3 Core - Bug #83457: TCA renderType selectCheckBox didn't check minitemsClosed2018-01-03

Actions
Actions #1

Updated by Andreas Kienast about 3 years ago

  • Related to Task #87324: Split FormEngine.js into smaller chunks added
Actions #2

Updated by Gerrit Code Review about 3 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/67317

Actions #3

Updated by Gerrit Code Review about 3 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/67317

Actions #4

Updated by Gerrit Code Review about 3 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/67317

Actions #5

Updated by Andreas Kienast about 3 years ago

  • Is duplicate of Bug #83457: TCA renderType selectCheckBox didn't check minitems added
Actions #6

Updated by Andreas Kienast about 3 years ago

  • Status changed from Under Review to Closed
Actions #7

Updated by Gerrit Code Review about 3 years ago

  • Status changed from Closed to Under Review

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/67317

Actions #8

Updated by Gerrit Code Review about 3 years ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/67317

Actions #9

Updated by Andreas Fernandez about 3 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #10

Updated by Gerrit Code Review about 3 years ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch 10.4 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/67356

Actions #11

Updated by Andreas Fernandez about 3 years ago

  • Status changed from Under Review to Resolved
Actions #12

Updated by Benni Mack almost 3 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF