Bug #93275

Custom backend loginLogo – without an explicit loginLogoAlt settings – causes TypeError

Added by Benjamin Franzke 9 months ago. Updated 8 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend User Interface
Target version:
Start date:
2021-01-12
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
11
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

in […]/typo3/sysext/backend/Classes/Controller/LoginController.php line 412

(1/1) TypeError
trim() expects parameter 1 to be string, null given
  $logoAlt = trim($extConf['loginLogoAlt']);

The issue is that the loginLogoAlt index is accessed without checking availability.
Threfore a null coalescing operator should be added.


Related issues

Related to TYPO3 Core - Task #92628: Linked TYPO3-Logo has no discernible textClosed2020-10-21

Actions
#1

Updated by Benjamin Franzke 9 months ago

  • Related to Task #92628: Linked TYPO3-Logo has no discernible text added
#2

Updated by Gerrit Code Review 9 months ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/67437

#3

Updated by Gerrit Code Review 9 months ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/67437

#4

Updated by Benjamin Franzke 9 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#5

Updated by Benni Mack 8 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF