Bug #93509

Pages with "editlock" are no longer visible in page tree and cannot be selected as link targets for page links

Added by Sybille Peters 2 months ago. Updated about 1 month ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Pagetree
Target version:
-
Start date:
2021-02-14
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
11
PHP Version:
Tags:
editlock,pagetree
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

The behaviour of the field pages.editlock ("Restrict editing by non-Admins") seems to have changed:

In latest master, if editlock is activated on a page, the page is no longer visible for non-admin editors in the page tree.

This also makes it impossible to select the page as link target when creating a page link.

In TYPO3 9 and 10:

- pages with editlock are visible in page tree
- pages (and content) with editlock cannot be edited (no page/pencil icon)
- links to pages with editlock can be created (as page is displayed in page tree)

In current master:

- pages with editlock not accessible at all, not in page tree, not when creating a page link, not when entering the page uid in the search field.

#1

Updated by Guido Schmechel about 1 month ago

Is this still valid? Cant reproduce with the current master

#2

Updated by Sybille Peters about 1 month ago

  • Status changed from New to Closed

No, I cannot reproduce it with current master. Closing.

Also available in: Atom PDF