Bug #93533

No pseudo-site found in root line of page <sys_category.uid> on sys_category edit

Added by Tobias Gaertner 8 months ago. Updated 8 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2021-02-17
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
9
PHP Version:
7.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description


(1/1) #1534710048 TYPO3\CMS\Core\Exception\SiteNotFoundException

No pseudo-site found in root line of page 9999

Tested: TYPO3 9.5.24

Reproduce:
- create a sys_category where sys_category.uid does not exist in pages.uid (you can e.g. edit the record in the database and set uid to 9999 or simular)
- now got to the BE List module and edit this sys_category

1. why is this checked at all?
2. if, it should be checked against sys_category.pid


Files

stacktrace.txt (409 KB) stacktrace.txt Tobias Gaertner, 2021-02-17 13:56

Related issues

Is duplicate of TYPO3 Core - Bug #92331: No pseudo-site found in root line of pageClosed2020-09-17

Actions
#1

Updated by Tobias Gaertner 8 months ago

Just checked - its not reproducible in v10

#2

Updated by Tobias Gaertner 8 months ago

  • Description updated (diff)
#4

Updated by Jonas Eberle 8 months ago

I can confirm.

It happens while evaluating a displayCond for sys_category.slug. Core does not add that field - in my case it was added by EXT:news.

In EXT:news/Configuration/TCA/Overrides/sys_category.php:

'displayCond' => 'USER:' . \TYPO3\CMS\Core\Compatibility\PseudoSiteTcaDisplayCondition::class . '->isInPseudoSite:pages:false',

It seems to have been fixed with https://github.com/georgringer/news/commit/20e9866807616fa1ca55a2c43a516a29705ffca9 and is released with EXT:news v8.5.2.

Removing that condition fixes it for me, too.

Funnily I've seen that error several times in the log over the last years. Happy it's gone now :)

#5

Updated by Tobias Gaertner 8 months ago

Right - confirm that its related to news.
nice so we can update news to get rid of that error.

#6

Updated by Jonas Eberle 8 months ago

  • Is duplicate of Bug #92331: No pseudo-site found in root line of page added
#7

Updated by Jonas Eberle 8 months ago

  • Status changed from New to Closed

Also available in: Atom PDF