Bug #93639

Having to enter account information periodically - makes workin with extension scanner more difficult

Added by Sybille Peters about 2 months ago. Updated about 2 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Install Tool
Target version:
-
Start date:
2021-03-03
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
9
PHP Version:
Tags:
backend usability, extension scanner, security
Complexity:
Is Regression:
Sprint Focus:

Description

It is now necessary to login again for some operations as system maintainer. This is also necessary for the extension scanner even though it is readonly and does not make any changes.

While working with the extension scanner, making the changes in the files, then rescanning again, you often get a timeout where it is necessary to login again.

Also, you can't login from the extension scanner, you have to leave it, login and then open it again.

I am currently working with this in TYPO3 9, have not tested yet with later version.


Files

extensionscanner2.png (69.9 KB) extensionscanner2.png Sybille Peters, 2021-03-03 12:54
extensionscanner.png (74.4 KB) extensionscanner.png Sybille Peters, 2021-03-03 12:55

Related issues

Related to TYPO3 Core - Bug #93160: Add option to disable Install Tool Sudo Mode for developmentResolved2020-12-22

Actions
#1

Updated by Sybille Peters about 2 months ago

Also, sometimes it will timeout but not show that it has timed out:

in comparison to:

#2

Updated by Oliver Bartsch about 2 months ago

Hi Sybille, I assume you are referring to the "sudo mode", right? If so, are you using the extension scanner in production or development context? With the latter, you no longer have to authenticate since #93160.

#3

Updated by Sybille Peters about 2 months ago

  • Status changed from New to Closed

Ah, cool. That is very helpful.

I am using 9.5.24 with "Configuration Presets" set to "Debug". Is there anything else I must do?

I will close now as it seems to have been handled, hope I can get this working in my site too.

#4

Updated by Sybille Peters about 2 months ago

  • Related to Bug #93160: Add option to disable Install Tool Sudo Mode for development added
#5

Updated by Sybille Peters about 2 months ago

Never mind, I found info: https://usetypo3.com/application-context.html

Just never needed this before.

Also available in: Atom PDF