Project

General

Profile

Actions

Bug #93867

closed

Flash messages are not shown with EXT:felogin

Added by Xavier Perseguers almost 3 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
felogin
Target version:
Start date:
2021-04-07
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
11
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Step to reproduce:

  1. Show the login form (plugin, default method)
  2. Click the link to ask to reset your password
  3. Enter your username or email address and submit
  4. You get redirected to the login form

What is missing is a Flash message on the login form telling you that an email has been sent bla bla bla.

The Flash message is actually generated and persisted in DB in ses_data from the session in fe_sessions but the session ID "changes" when going back to the login form and:

  • The Flash message is not shown
  • The fe_session table is being polluted with dangling sessions

Possibly related to #93386

Actions #1

Updated by Oliver Bartsch over 2 years ago

  • Status changed from New to Needs Feedback

Hi Xavier, just checked this in latest master and can no longer reproduce. Could you please check, if this issue still exists for you?

Actions #2

Updated by Xavier Perseguers over 2 years ago

  • Status changed from Needs Feedback to Resolved
  • % Done changed from 0 to 100

In fact, looks like it's working now. Thanks for commenting.

Actions #3

Updated by Oliver Bartsch over 2 years ago

  • Status changed from Resolved to Closed

Alright, then I'll close this issue now. Thanks for the fast feedback.

Actions

Also available in: Atom PDF