Bug #94323

Story #94322: Inconsistencies in showing page TSconfig in Info module

Fix naming inconsistencies in module "Info > Page TSconfig"

Added by Sybille Peters about 2 months ago. Updated about 1 month ago.

Status:
Resolved
Priority:
Should have
Assignee:
-
Category:
Backend User Interface
Target version:
-
Start date:
2021-06-12
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
11
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

this is a subtask for #94322:

1. Consistent naming in the select list

Currently, there is a mixture of showing the objects in

1. their technical representation as they are used in TSConfig, e.g. "TCEMAIN"
2. in a full plaintext representation , e.g. "Module: Web>Page"
3. and a mixture , e.g. " "Module key (mod) with overruling user settings"


Files

tsconfig_select.png (24.4 KB) tsconfig_select.png Sybille Peters, 2021-06-12 07:37
tsconfig_select_new.png (34 KB) tsconfig_select_new.png Sybille Peters, 2021-06-12 07:46
#1

Updated by Sybille Peters about 2 months ago

Proposal:

  • All
  • Module [mod.]
  • Module: Web>Page [mod.web_layout.]
  • Module: Web>View [mod.web_view.]
  • Module: Web>Modules [mod.web_modules.] - no longer exists, will be removed
  • Module: Web>View [mod.web_view.]
  • Module: Web>Info [mod.web_info.]
  • Module: Web>Template [mod.web_ts.]
  • [RTE.]
  • [TCAdefault.]
  • [TCEFORM.]
  • [TCEMAIN.]
  • [user.]
  • View TSconfig fields content

So,

  • the technical representation is always added in brackets ([])
  • the entry for mod is shortened (perhaps the explanation can be added somewhere else)
  • I decided against having descriptive texts for RTE, TCAdefault etc. because as far as I know we don't have them and this might require a joint effort to find good terms and would take longer.

#2

Updated by Gerrit Code Review about 2 months ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/69467

#3

Updated by Gerrit Code Review about 2 months ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/69467

#4

Updated by Gerrit Code Review about 1 month ago

Patch set 1 for branch 10.4 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/69553

#5

Updated by Sybille Peters about 1 month ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF