Project

General

Profile

Actions

Bug #94483

closed

CSH show more arrow not visible

Added by Nikita Hovratov about 3 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend User Interface
Target version:
-
Start date:
2021-07-05
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
11
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

If a csh popover has an additional link to open a popup, it should display an arrow to symbolise that.
Although it is correctly rendered in the help link:

<span class="help-link" data-table="pages" data-field="doktype" data-loaded="true" data-html="true" data-original-title="" data-placement="auto" data-trigger="click" data-content="<p class=&quot;help-short help-has-link&quot;>Page Type determines whether the page is normal webpage, a shortcut to another webpage, or used in other internal ways.<span class=&quot;t3js-icon icon icon-size-small icon-state-default icon-actions-view-go-forward&quot; data-identifier=&quot;actions-view-go-forward&quot;>
    <span class=&quot;icon-markup&quot;>
<svg class=&quot;icon-color&quot; role=&quot;img&quot;><use xlink:href=&quot;/typo3/sysext/core/Resources/Public/Icons/T3Icons/sprites/actions.svg#actions-arrow-down-right&quot; /></svg>
    </span>

</span></p>" aria-describedby="popover397294"><abbr class="help-teaser">Type</abbr></span>

.. it is not correctly copied over to the popover body (the svg part is missing):

<div class="popover-content"><p class="help-short help-has-link">Page Type determines whether the page is normal webpage, a shortcut to another webpage, or used in other internal ways.<span class="t3js-icon icon icon-size-small icon-state-default icon-actions-view-go-forward">
    <span class="icon-markup">

    </span>

</span></p></div>

Related issues 1 (0 open1 closed)

Related to TYPO3 Core - Task #97312: Remove CSHClosedMichael Telgkamp2022-04-05

Actions
Actions #1

Updated by Nikita Hovratov about 3 years ago

I guess the svg is sanitized because of security reasons: https://getbootstrap.com/docs/5.0/getting-started/javascript/#sanitizer

Actions #2

Updated by Stephan Jorek over 2 years ago

Nikita Hovratov wrote:

If a csh popover has an additional link to open a popup, it should display an arrow to symbolise that.
Although it is correctly rendered in the help link:

[...]

.. it is not correctly copied over to the popover body (the svg part is missing):

[...]

I can confirm this issue, but I didn't investigate yet, if the assumption regarding the SVG-Sanatizer is correct.

Actions #3

Updated by Riccardo De Contardi almost 2 years ago

  • TYPO3 Version changed from 10 to 11
Actions #4

Updated by Christian Kuhn over 1 year ago

Actions #5

Updated by Christian Kuhn over 1 year ago

  • Status changed from New to Closed

Hey. I hope it's fine to close here since we removed csh entirely in v12 ;)

Actions

Also available in: Atom PDF