Bug #94711

Date input with lower range inserts value even if no value is set since TYPO3 10.4.18

Added by Manfred Egger 3 months ago. Updated 3 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2021-08-04
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
10
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

In some of our own extensions the fields starttime and endtime with a lower value for range:

'starttime' => array(
    'exclude' => 1,
    'label' => 'LLL:EXT:core/Resources/Private/Language/locallang_general.xlf:LGL.starttime',
    'config' => array(
        'type' => 'input',
        'renderType' => 'inputDateTime',
        'size' => 13,
        'eval' => 'datetime',
        'default' => 0,
        'range' => array(
            'lower' => mktime(0, 0, 0, date('m'), date('d'), date('Y'))
        ),
        'behaviour' => array(
            'allowLanguageSynchronization' => true,
        ),
    ),
),

Until TYPO3 10.4.17 when we create new records, the starttime and endtime is empty after save. Since TYPO3 10.4.18 the current date is inserted in both fields after save, allthough the fields were empty.


Related issues

Is duplicate of TYPO3 Core - Bug #94621: startime/endtime are forced to "today" after savingClosed

Actions
#1

Updated by Wouter Wolters 3 months ago

  • Is duplicate of Bug #94621: startime/endtime are forced to "today" after saving added
#2

Updated by Wouter Wolters 3 months ago

  • Status changed from New to Closed

Hi, thanks for the report. This issue is known and already solved in https://review.typo3.org/c/Packages/TYPO3.CMS/+/70135 and will be included in the next release. Which is planned for today according to messages in TYPO3 coredev Slack.

Also available in: Atom PDF