Bug #94960

References to formPersistenceIdentifier

Added by Achim Fritz 3 months ago. Updated 3 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Form Framework
Target version:
-
Start date:
2021-08-23
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
11
PHP Version:
7.4
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

having References to formPersistenceIdentifier from custom table, e.g.:

mysql> select tablename,softref_key,flexpointer,ref_table from sys_refindex where softref_key  like '%form%';
+--------------+---------------------------+------------------------------------------------+-----------+
| tablename    | softref_key               | flexpointer                                    | ref_table |
+--------------+---------------------------+------------------------------------------------+-----------+
| tt_content   | formPersistenceIdentifier | sDEF/lDEF/settings.persistenceIdentifier/vDEF/ | sys_file  |
| tx_b13_items | formPersistenceIdentifier | sDEF/lDEF/settings.persistenceIdentifier/vDEF/ | sys_file  |
+--------------+---------------------------+------------------------------------------------+-----------+

(here "tx_b13_items" is my custom table)

Click "Form" Module in Backend to "Form Management"

the Form is listed with 2 References, click the "2" in the Reference Column, only one reference is shown (the one to tt_content)

this happens because on SQL-Query for count reference have no constraint to "tablename" column, but SQL-Query for fetching references by form-identifier have constraint to "tablename='tt_content'"

#1

Updated by Gerrit Code Review 3 months ago

  • Status changed from New to Under Review

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/70722

#2

Updated by Gerrit Code Review 3 months ago

Patch set 1 for branch 10.4 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/70693

#3

Updated by Anonymous 3 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#4

Updated by Benni Mack 3 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF