Project

General

Profile

Actions

Bug #95224

closed

SystemEmail could not be loaded when publising a version (workspace)

Added by Simon Ouellet almost 3 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Workspaces
Target version:
-
Start date:
2021-09-15
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
10
PHP Version:
7.4
Tags:
composer
Complexity:
Is Regression:
Sprint Focus:

Description

Oops, an error occurred!
The Fluid template files "/var/www/public/typo3/sysext/workspaces/Resources/Private/Layouts/SystemEmail.html", "/var/www/public/typo3/sysext/workspaces/Resources/Private/Layouts/SystemEmail" could not be loaded.

The SystemEmail Layout is located in core/Resources/Private/Layouts/.
The following path should be updated

workspaces/ext_localconf.php

\TYPO3\CMS\Core\Utility\ExtensionManagementUtility::addPageTSConfig('
tx_workspaces.emails.layoutRootPaths.90 = EXT:workspaces/Resources/Private/Layouts/
tx_workspaces.emails.partialRootPaths.90 = EXT:workspaces/Resources/Private/Partials/
tx_workspaces.emails.templateRootPaths.90 = EXT:workspaces/Resources/Private/Templates/Email/
tx_workspaces.emails.format = html
');

workaround: https://github.com/TYPO3/typo3/blob/7aad9f6dea9246a1cc64f1b076e106605db3e04c/typo3/sysext/core/Documentation/Changelog/10.3/Feature-90411-HTML-basedWorkspaceNotificationEmailsOnStageChange.rst

Actions #1

Updated by Gerrit Code Review almost 3 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/71095

Actions #2

Updated by Wouter Wolters almost 3 years ago

  • Status changed from Under Review to Needs Feedback

The settings just extend the already existing MAIL configuration from $GLOBALS['TYPO3_CONF_VARS']['MAIL']). This makes it possible to override those Layouts/Templates (https://github.com/TYPO3/typo3/blob/master/typo3/sysext/workspaces/Classes/Notification/StageChangeNotification.php#L164). This is the usual workflow for fluid templates and should not be touched.

Did you maybe mess up $GLOBALS['TYPO3_CONF_VARS']['MAIL'] configuration by removing the defaults, set in the DefaultConfiguration.php (https://github.com/TYPO3/typo3/blob/master/typo3/sysext/core/Configuration/DefaultConfiguration.php#L1467) ?

With a fresh v11 Oliver Bartsch can't reproduce this bug.

Actions #3

Updated by Simon Ouellet almost 3 years ago

You are right, I've messed up my MAIL configuration.

Actions #4

Updated by Oliver Bartsch almost 3 years ago

  • Status changed from Needs Feedback to Closed

Thanks for you feedback. I'll close this issue now. In case you encounter similar problems, please just create a new issue with a reference to this one.

Actions

Also available in: Atom PDF