Bug #95992

Package artifact not found. Run "composer install" to create it.

Added by Dennis Metz 7 months ago. Updated 5 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
Start date:
2021-11-16
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
11
PHP Version:
7.4
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

After updating Composer from 11.5.2 to 11.5.3, I get the following error message:
Package artifact not found. Run "composer install" to create it.

Packages that have been updated:
- Upgrading typo3fluid/fluid (2.7.0 => 2.7.1): Extracting archive
- Upgrading typo3/cms-core (v11.5.2 => v11.5.3): Extracting archive
- Upgrading typo3/cms-extbase (v11.5.2 => v11.5.3): Extracting archive
- Upgrading typo3/cms-fluid (v11.5.2 => v11.5.3): Extracting archive
- Upgrading typo3/cms-install (v11.5.2 => v11.5.3): Extracting archive
- Upgrading typo3/cms-frontend (v11.5.2 => v11.5.3): Extracting archive
- Upgrading typo3/cms-extensionmanager (v11.5.2 => v11.5.3): Extracting archive
- Upgrading typo3/cms-recordlist (v11.5.2 => v11.5.3): Extracting archive
- Upgrading typo3/cms-backend (v11.5.2 => v11.5.3): Extracting archive
- Upgrading typo3/cms-seo (v11.5.2 => v11.5.3): Extracting archive
- Upgrading typo3/cms-rte-ckeditor (v11.5.2 => v11.5.3): Extracting archive
- Upgrading typo3/cms-fluid-styled-content (v11.5.2 => v11.5.3): Extracting archive
- Upgrading typo3/cms-adminpanel (v11.5.2 => v11.5.3): Extracting archive
- Upgrading typo3/cms-belog (v11.5.2 => v11.5.3): Extracting archive
- Upgrading typo3/cms-beuser (v11.5.2 => v11.5.3): Extracting archive
- Upgrading typo3/cms-dashboard (v11.5.2 => v11.5.3): Extracting archive
- Upgrading typo3/cms-filelist (v11.5.2 => v11.5.3): Extracting archive
- Upgrading typo3/cms-filemetadata (v11.5.2 => v11.5.3): Extracting archive
- Upgrading typo3/cms-form (v11.5.2 => v11.5.3): Extracting archive
- Upgrading typo3/cms-impexp (v11.5.2 => v11.5.3): Extracting archive
- Upgrading typo3/cms-indexed-search (v11.5.2 => v11.5.3): Extracting archive
- Upgrading typo3/cms-info (v11.5.2 => v11.5.3): Extracting archive
- Upgrading typo3/cms-lowlevel (v11.5.2 => v11.5.3): Extracting archive
- Upgrading typo3/cms-recycler (v11.5.2 => v11.5.3): Extracting archive
- Upgrading typo3/cms-redirects (v11.5.2 => v11.5.3): Extracting archive
- Upgrading typo3/cms-reports (v11.5.2 => v11.5.3): Extracting archive
- Upgrading typo3/cms-scheduler (v11.5.2 => v11.5.3): Extracting archive
- Upgrading typo3/cms-setup (v11.5.2 => v11.5.3): Extracting archive
- Upgrading typo3/cms-tstemplate (v11.5.2 => v11.5.3): Extracting archive
- Upgrading typo3/cms-viewpage (v11.5.2 => v11.5.3): Extracting archive
- Upgrading typo3/cms-workspaces (v11.5.2 => v11.5.3): Extracting archive


Files

composer.json (1.78 KB) composer.json Dennis Metz, 2021-11-16 12:17
composer-show.txt (12 KB) composer-show.txt Dennis Metz, 2021-11-16 12:17

Related issues

Related to TYPO3 Core - Bug #95897: Deployment of ComposerPackageArtifact needs special knowledgeResolvedSimon Gilli2021-11-07

Actions
Related to TYPO3 Core - Task #96017: Relax PackageArtifactBuilder to support PHP 7.1ResolvedSimon Gilli2021-11-17

Actions
#1

Updated by Oliver Hader 7 months ago

  • Related to Bug #95897: Deployment of ComposerPackageArtifact needs special knowledge added
#2

Updated by Oliver Hader 7 months ago

  • Status changed from New to Needs Feedback

Which composer version has been used?

I could not reproduce the behavior using v2.1.12 from the stable release stream:

composer --version
Composer version 2.1.12 2021-11-09 16:02:04

composer update and composer install finished without problems, artifact file at vendor/typo3/PackageArtifact.php has been generated (previously this was located in var/build/).

#3

Updated by Dennis Metz 7 months ago

Oliver Hader wrote in #note-2:

Which composer version has been used?

I could not reproduce the behavior using v2.1.12 from the stable release stream:

[...]

composer update and composer install finished without problems, artifact file at vendor/typo3/PackageArtifact.php has been generated (previously this was located in var/build/).

composer --version
Composer version 2.1.12 2021-11-09 16:02:04
but has also not worked with 2.1.11

The only third-party packages I still use are these
"helhum/typo3-console": "^7.0",
"helhum/typo3-secure-web": "^0.3",
"georgringer/news": "9.1.*",
"lochmueller/staticfilecache": "12.3.*",

#4

Updated by Helmut Hummel 7 months ago

Dennis Metz wrote in #note-3:

artifact file at vendor/typo3/PackageArtifact.php has been generated

Can you verify that this file exists?
When exactly do you get this error message? On CLI? During a web request?
Can you share the output of "composer show" of your project?
Can you share your composer.json file?

#5

Updated by Oliver Hader 7 months ago

The error message shown above is triggered in https://github.com/TYPO3/typo3/blob/v11.5.3/typo3/sysext/core/Classes/Package/Cache/ComposerPackageArtifact.php#L80-L83

So, a bunch of things that come to my mind:

  • Are you using a custom vendor-dir setting in composer.json, other than vendor?
  • Which operating system is used? Is it installed on a network share or similar?
  • Can you make sure, that vendor/typo3/PackageArtifact.php can be created and that location is writable in the file system?
#6

Updated by Helmut Hummel 7 months ago

Oliver Hader wrote in #note-5:

The error message shown above is triggered in https://github.com/TYPO3/typo3/blob/v11.5.3/typo3/sysext/core/Classes/Package/Cache/ComposerPackageArtifact.php#L80-L83

So, a bunch of things that come to my mind:

  • Are you using a custom vendor-dir setting in composer.json, other than vendor?

It still works with any configured vendor folder.

  • Which operating system is used? Is it installed on a network share or similar?

That would be interesting to know, indeed.

  • Can you make sure, that vendor/typo3/PackageArtifact.php can be created and that location is writable in the file system?

Since there are other files in @vendor/typo3 which are written during a composer install, this should not be an issue, or otherwise it would already fail hard

#7

Updated by Dennis Metz 7 months ago

I use Ubuntu 20.04.3 LTS (WSL)
PHP7.4 (CLI/FPM)

"extra": {
"typo3/cms": {
"web-dir": "web",
"root-dir": "private"
}
},

Can you verify that this file exists?
> File does not exist
When exactly do you get this error message? On CLI? During a web request?
> Web Request: domain.tld, domain.tld/typo3
Can you share the output of "composer show" of your project?
Can you share your composer.json file?
-> Files are uploaded

Are you using a custom vendor-dir setting in composer.json, other than vendor?
> No, just web/private folders
Which operating system is used? Is it installed on a network share or similar?
> WSL (Windows Subsystem for Linux)
Can you make sure, that vendor/typo3/PackageArtifact.php can be created and that location is writable in the file system?
-> Directory is writable

#8

Updated by Dennis Metz 7 months ago

sorry for the formatting - sent it without looking first...

#9

Updated by Helmut Hummel 7 months ago

Dennis Metz wrote in #note-8:

sorry for the formatting - sent it without looking first...

Can you fix it, so that it is clearly visible which are quotes and which are your answers?

In general, I'm still failing to reproduce, even with your full composer.json file.

Can you post the full content of your vendor/typo3 folder after doing a full "composer update"?

#10

Updated by Dennis Metz 7 months ago

Vendor folder:

drwxrwxrwx 1 dennis dennis 512 Nov 16 11:48 .
drwxrwxrwx 1 dennis dennis 512 Nov 16 13:20 ..
-rwxrwxrwx 1 dennis dennis 178 Nov 16 11:48 autoload.php
drwxrwxrwx 1 dennis dennis 512 Nov 16 11:47 bacon
drwxrwxrwx 1 dennis dennis 512 Nov 16 11:48 bin
drwxrwxrwx 1 dennis dennis 512 Nov 16 11:47 christian-riesen
drwxrwxrwx 1 dennis dennis 512 Nov 16 11:48 christophlehmann
drwxrwxrwx 1 dennis dennis 512 Nov 16 11:48 composer
drwxrwxrwx 1 dennis dennis 512 Nov 16 11:47 dasprid
drwxrwxrwx 1 dennis dennis 512 Nov 16 11:47 doctrine
drwxrwxrwx 1 dennis dennis 512 Nov 16 11:47 egulias
drwxrwxrwx 1 dennis dennis 512 Nov 16 11:47 enshrined
drwxrwxrwx 1 dennis dennis 512 Nov 16 11:48 georgringer
drwxrwxrwx 1 dennis dennis 512 Nov 16 11:47 guzzlehttp
drwxrwxrwx 1 dennis dennis 512 Nov 16 11:47 helhum
drwxrwxrwx 1 dennis dennis 512 Nov 16 11:48 lochmueller
drwxrwxrwx 1 dennis dennis 512 Nov 16 11:47 lolli42
drwxrwxrwx 1 dennis dennis 512 Nov 16 11:47 masterminds
drwxrwxrwx 1 dennis dennis 512 Nov 16 11:47 nikic
drwxrwxrwx 1 dennis dennis 512 Nov 16 11:47 phpdocumentor
drwxrwxrwx 1 dennis dennis 512 Nov 16 11:47 psr
drwxrwxrwx 1 dennis dennis 512 Nov 16 11:47 ralouphie
drwxrwxrwx 1 dennis dennis 512 Nov 16 11:47 scssphp
drwxrwxrwx 1 dennis dennis 512 Nov 16 11:47 sws
drwxrwxrwx 1 dennis dennis 512 Nov 16 11:47 symfony
drwxrwxrwx 1 dennis dennis 512 Nov 16 11:48 typo3
drwxrwxrwx 1 dennis dennis 512 Nov 16 11:47 typo3fluid
drwxrwxrwx 1 dennis dennis 512 Nov 16 11:48 undefined
drwxrwxrwx 1 dennis dennis 512 Nov 16 11:47 webmozart

#11

Updated by Simon Gilli 7 months ago

Can you post the full content of your vendor/typo3 folder after doing a full "composer update"?

vendor/typo3 please, not the vendor.

#12

Updated by Dennis Metz 7 months ago

Oh, sorry:

drwxrwxrwx 1 dennis dennis 512 Nov 16 14:05 .
drwxrwxrwx 1 dennis dennis 512 Nov 16 14:05 ..
-rwxrwxrwx 1 dennis dennis 824 Nov 16 14:06 autoload-include.php
drwxrwxrwx 1 dennis dennis 512 Nov 16 11:47 class-alias-loader
drwxrwxrwx 1 dennis dennis 512 Nov 16 11:47 cms-cli
drwxrwxrwx 1 dennis dennis 512 Nov 16 11:47 cms-composer-installers
drwxrwxrwx 1 dennis dennis 512 Nov 16 11:47 html-sanitizer
-rwxrwxrwx 1 dennis dennis 157K Nov 16 14:05 PackageArtifact.php
drwxrwxrwx 1 dennis dennis 512 Nov 16 11:47 phar-stream-wrapper
drwxrwxrwx 1 dennis dennis 512 Nov 16 11:47 symfony-psr-event-dispatcher-adapter

#13

Updated by Dennis Metz 7 months ago

Looks like the error is gone....

I uninstalled and reinstalled "News", suddenly everything works again...

I really dont know how this could happen

#14

Updated by Helmut Hummel 7 months ago

  • Status changed from Needs Feedback to Closed

Dennis Metz wrote in #note-13:

Looks like the error is gone....

I uninstalled and reinstalled "News", suddenly everything works again...

I really dont know how this could happen

OK, thanks for the feedback.

#15

Updated by Simon Gilli 7 months ago

  • Related to Task #96017: Relax PackageArtifactBuilder to support PHP 7.1 added
#16

Updated by Henrik Ziegenhain 7 months ago

Well, unfortunately I have a similar problem.

When we deploy your project based 11 LTS via Gitlab CI the pipeline fails when it requests typo3_console.

Uncaught TYPO3 Exception Call to undefined method Composer\InstalledVersions::getInstallPath()
thrown in file releases/1/private/typo3/sysext/core/Classes/Core/Bootstrap.php

Same error when calling typo3cms binary directly from CLI.

To fix it, we have to run `composer update (--no-dev)` on Webserver. Afterwards typo3_console is working fine.
Something realy tricky changed from v10 to v11 at this point. But we don't find the issue

#17

Updated by Helmut Hummel 5 months ago

Henrik Ziegenhain wrote in #note-16:

Well, unfortunately I have a similar problem.

When we deploy your project based 11 LTS via Gitlab CI the pipeline fails when it requests typo3_console.

[...]

Same error when calling typo3cms binary directly from CLI.

To fix it, we have to run `composer update (--no-dev)` on Webserver. Afterwards typo3_console is working fine.
Something realy tricky changed from v10 to v11 at this point. But we don't find the issue

Please make sure your pipeline does NOT ignore platform requirements when performing the composer install.
And make sure to use at least Composer version 2.1

Also available in: Atom PDF