Project

General

Profile

Actions

Bug #96535

closed

System news (backend login messages) don't render links anymore

Added by Stefan P about 2 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Won't have this time
Assignee:
-
Category:
Backend User Interface
Target version:
-
Start date:
2022-01-14
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
10
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

We use system news in the BE login screen quite intense. Up to version 9 we could use links in there (it's a normal RTE after all) and they were displayed and clickable.

I just noticed that links in system news in TYPO3 10 get totally removed from the output (replaced with empty string). No matter if you use <a> tags ( <a href="https://domain">foo</a> becomes empty string as a whole) or just a literal url ( https://forge.typo3.org/ also becomes an emtpy string).

Since thsi is an undocumented change (could not find anything regarding this) from 9 to 10 I flagged this as a regression. Is probably still the same in TYPO 11.


Related issues 3 (0 open3 closed)

Related to TYPO3 Core - Feature #95176: Introduce <f:transform.html> view-helperClosed2021-09-10

Actions
Related to TYPO3 Core - Bug #95179: Transform internal URIs in backend user interfaceClosed2021-09-10

Actions
Related to TYPO3 Core - Bug #67556: System news cannot render RTE contentClosed2015-06-17

Actions
Actions #1

Updated by Stefan P about 2 years ago

Actually, v11 seems to work correctly again.

v10 has this: <f:format.html>{item.content}</f:format.html>

v11 has this: {item.content -> f:transform.html() -> f:sanitize.html()}

Actions #2

Updated by Oliver Hader about 2 years ago

  • Related to Feature #95176: Introduce <f:transform.html> view-helper added
Actions #3

Updated by Oliver Hader about 2 years ago

  • Related to Bug #95179: Transform internal URIs in backend user interface added
Actions #4

Updated by Oliver Hader about 2 years ago

  • Related to Bug #67556: System news cannot render RTE content added
Actions #5

Updated by Oliver Hader about 2 years ago

f:transform.html was introduced in TYPO3 v11, not available in TYPO3 v10.

According to #67556 that did not seem to work six years ago, mid 2015...

Actions #6

Updated by Oliver Hader about 2 years ago

  • Is Regression changed from Yes to No
Actions #7

Updated by Oliver Hader about 2 years ago

  • Status changed from New to Closed
  • Priority changed from Should have to Won't have this time

This most probably won't be fixed in TYPO3 v10 anymore, which is in priority bug-fixing mode only.

Actions

Also available in: Atom PDF