Project

General

Profile

Actions

Bug #99725

closed

Undefined array key when copy pasting a page PHP 8.1

Added by Wilfrid Marie over 1 year ago. Updated 13 days ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2023-01-26
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
11
PHP Version:
8.1
Tags:
Complexity:
Is Regression:
Sprint Focus:
On Location Sprint

Description

Hello everyone,
I'm using TYPO3 v11.5.22 with PHP 8.1
When i try to copy and paste a page, i get this error (for this error to happen, the page needs to have content elements in it), i tried with a empty page and i have no errors.
Despite the error, the paste works and the page is created.


Files

Actions #1

Updated by Wilfrid Marie over 1 year ago

You will the screenshot of the error in the attached files

Actions #2

Updated by Thomas Hohn over 1 year ago

Hi - could you provide more info. How is the copy-paste done?

Actions #3

Updated by Benni Mack about 1 year ago

  • Sprint Focus set to Stabilization Sprint
Actions #4

Updated by Benni Mack 12 months ago

  • Sprint Focus changed from Stabilization Sprint to On Location Sprint
Actions #5

Updated by Christian Buelter 12 months ago

  • TYPO3 Version changed from 11 to 13

I could not reproduce this issue on TYPO3 13.0.0-dev, PHP 8.1

I copied a page which had been created by the "styleguide" extension and contained content elements once via drag&drop and once via the context menu.

In both cases the page had been copied without errors.

Actions #6

Updated by Christian Buelter 12 months ago

  • TYPO3 Version changed from 13 to 11
Actions #7

Updated by Gerrit Code Review 12 months ago

  • Status changed from New to Under Review

Patch set 1 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/80373

Actions #8

Updated by Gerrit Code Review 12 months ago

Patch set 2 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/80373

Actions #9

Updated by Gerrit Code Review 12 months ago

Patch set 3 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/80373

Actions #10

Updated by Gerrit Code Review 12 months ago

Patch set 1 for branch 12.4 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/80412

Actions #11

Updated by Gerrit Code Review 12 months ago

Patch set 1 for branch 11.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/80413

Actions #12

Updated by Gordon Brüggemann 12 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #13

Updated by Benni Mack 13 days ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF