Project

General

Profile

Actions

Bug #100940

closed

Extbase Exception The default controller for extension "Form" and plugin "Formframework" can not be determined when circular redirect

Added by RVVN no-lastname-given 9 months ago. Updated 6 months ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
Redirect Handling
Target version:
-
Start date:
2023-06-01
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
11
PHP Version:
7.4
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Hi,

When a page containing a extbase plugin is renamed from "Page A" to "Page B", then back to "Page A", a circular redirect is created.

In that case, using a form plugin for instance, the following exception is raised :

The default controller for extension "Form" and plugin "Formframework" can not be determined. 

Please check for TYPO3\CMS\Extbase\Utility\ExtensionUtility::configurePlugin() in your ext_localconf.php.
Actions #1

Updated by RVVN no-lastname-given 9 months ago

  • Description updated (diff)
Actions #2

Updated by Stefan Bürk 9 months ago

  • Assignee set to Stefan Bürk
Actions #3

Updated by Stefan Bürk 9 months ago

  • Category set to Redirect Handling
Actions #4

Updated by RVVN no-lastname-given 9 months ago

After further investigation, it seems to come from Flux extension.
Actual TER version breaks all Extbase plugin in a page with circular redirection.

When using the latest development version, there's no more exception.

See : https://github.com/FluidTYPO3/flux/issues/2076

Actions #5

Updated by Ralf Hübner 9 months ago

Hi!
I have a similar strange problem. I use felogin with a custom authentification service (external sso). If a user tries to log in this similar exception appears (maybe the first extension in the "order"). With reload the page the user is loggend in without any errors.

If I deactivate the extension that supposedly causes the error (the first in the "order"), then the next one (felogin) has the problem.

If I deactivate the custom auth service in ext_localconf (ExtensionManagementUtility::addService( ... available => false) and the login with locally users works without errors.

Actions #6

Updated by Stefan Bürk 9 months ago

@Ralf Hübner

Does your custom auth service does use any kind of extbase ? (repository/model) ? If yes, remove it. Won't work. To early for extbase.

Actions #7

Updated by Ralf Hübner 9 months ago

Thank you very much, that was helpful:

Indeed I have added static-info-country repro to the auth service because I have to determine between iso2/iso3 country code.

I had already tried to rollback my code but it won´t work neither - maybe due a cache issue.

Now I have removed all code of dependency incjection and deleted var/cache manually and after that it works again!

Actions #8

Updated by Stefan Bürk 9 months ago

Ralf Hübner wrote in #note-7:

Thank you very much, that was helpful:

Indeed I have added static-info-country repro to the auth service because I have to determine between iso2/iso3 country code.

I had already tried to rollback my code but it won´t work neither - maybe due a cache issue.

Now I have removed all code of dependency incjection and deleted var/cache manually and after that it works again!

V12 comes with core integrated countries. If I remember right, Georg Ringe has a backport of that to v11
as extension. So instead of using static_info_table/extbase you may require that extension and do your check with that ?

See: https://github.com/georgringer/country_backport

Actions #9

Updated by Ralf Hübner 9 months ago

Thank you again Stefan, very nice!

Actions #10

Updated by Stefan Bürk 8 months ago

  • Status changed from New to Closed

I'm closing this issue, as it was related to having extbase / extbase DI
in a middleware which leads to this fact.

Extbase DI is not suitable in such cases and not supported for that case.

Actions #11

Updated by Rémy DANIEL 6 months ago

In our case, the issue was solved (or worked around) by deleting circular sys_redirects.

Actions

Also available in: Atom PDF