Project

General

Profile

Actions

Bug #101677

closed

Update Wizzard Installtool broken?

Added by Christoph Werner 8 months ago. Updated 7 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Install Tool
Target version:
-
Start date:
2023-08-14
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
12
PHP Version:
8.1
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Hi!
I´ve tried to update an TYPO3 11.5.30 to 12.4.5 in the "old way" (no composer). But I struggle with errors in the Installtool (see screenshot).
In the console, some csp-related errors are showed (see screenshot).

Similar error pop up when try using "Check TCA in ext_tables.php" or "Remove Temporary Assets"

Best regards,
Chris

Setting:
- PHP 8.1
- Firefox / Edge
- Tried in two different Systems


Files

error_update_wizzard.jpg (180 KB) error_update_wizzard.jpg Error Update Wizzard Christoph Werner, 2023-08-14 10:35
csp.jpg (70.5 KB) csp.jpg CSP Christoph Werner, 2023-08-14 10:43
101677.png (727 KB) 101677.png Oliver Hader, 2023-08-25 07:10
Actions #1

Updated by Oliver Hader 8 months ago

Could not reproduce the mentioned behavior when using the standalone Install Tool with Edge and Firefox (see screenshot 101677.png).

It seems that those red alerts were coming from the server side. Did you check the logs in typo3temp/var/log or the PHP log?
The CSP violations are probably caused by [NoScript]:0 Prompt Hook installation ... log.js:32:13 - log.js does not belong to TYPO3, what is that?

Actions #2

Updated by Christoph Werner 8 months ago

Hi Oliver,

thanks for investigating!

Oliver Hader wrote in #note-1:

Could not reproduce the mentioned behavior when using the standalone Install Tool with Edge and Firefox (see screenshot 101677.png).

It seems that those red alerts were coming from the server side. Did you check the logs in typo3temp/var/log or the PHP log?
The CSP violations are probably caused by [NoScript]:0 Prompt Hook installation ... log.js:32:13 - log.js does not belong to TYPO3, what is that?

Didn´t get any entries in typo3temp/var/log.

But log.js gave me the right hint. Problem was the browserplugin "noscript" -> I need to disable it completely, setting to trust the domain doesn´t work (only for upgrading, backend works fine with active "noscript").
A bit strange: I´ve had tested it with a standard Edge too and got similar error like in the initial post. But i assume that it is also due to some setting on my computer.

Please close the ticket and have a nice weekend!
Best regards,
Chris

Actions #3

Updated by Georg Ringer 7 months ago

  • Status changed from Needs Feedback to Closed

closed as no issue in the core - thanks for your feedback

Actions

Also available in: Atom PDF