Project

General

Profile

Actions

Bug #102083

closed

Validation triggered for fields in fieldsets disabled by variants

Added by Mathias Brodala 10 months ago. Updated 11 days ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Form Framework
Target version:
Start date:
2023-10-04
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
11
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Given fields are placed in a fieldset and that fieldset is disabled using variants. Also given that these fields have validators.

Now if one tries to submit the form, it is displayed again without explanation. Inspection of the validation results shows that the validators of the fields have been triggered and couldn't validate the input of the fields. These fields could not be filled by the user since they are disabled together with their fieldset.

Validators of fields within disabled fieldsets should be ignored.

Actions #1

Updated by Gerrit Code Review 10 months ago

  • Status changed from New to Under Review

Patch set 1 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/81318

Actions #2

Updated by Gerrit Code Review 10 months ago

Patch set 2 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/81318

Actions #3

Updated by Gerrit Code Review 10 months ago

Patch set 3 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/81318

Actions #4

Updated by Gerrit Code Review 10 months ago

Patch set 4 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/81318

Actions #5

Updated by RVVN no-lastname-given 10 months ago

Could it be fixed for TYPO3v11 too ?

Actions #6

Updated by Mathias Brodala 10 months ago

Unfortunately no, since this is no priority bugfix. But you can always apply this as patch to your instance.

Actions #7

Updated by RVVN no-lastname-given 9 months ago

Mathias Brodala wrote in #note-6:

Unfortunately no, since this is no priority bugfix. But you can always apply this as patch to your instance.

We use legacy installation so we cannot "composer patch" (if you were talking about that way).

What defines "priority bugfix" ?
If the fix can be applied to v11 (which is the version set in this issue) LTS , why don't apply it ? :)

Actions #8

Updated by Mathias Brodala 9 months ago

RVVN no-lastname-given wrote in #note-7:

Mathias Brodala wrote in #note-6:

Unfortunately no, since this is no priority bugfix. But you can always apply this as patch to your instance.

We use legacy installation so we cannot "composer patch" (if you were talking about that way).

Then I strongly recommend to switch to Composer Mode ASAP.

What defines "priority bugfix" ?
If the fix can be applied to v11 (which is the version set in this issue) LTS , why don't apply it ? :)

This is not something I made up, see https://typo3.org/cms/roadmap

In other words: I'd happily have this merged into TYPO3v11 too, but the decision is not mine to make.

Actions #9

Updated by Gerrit Code Review 8 months ago

Patch set 5 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/81318

Actions #10

Updated by Gerrit Code Review 8 months ago

Patch set 6 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/81318

Actions #11

Updated by Gerrit Code Review 8 months ago

Patch set 1 for branch 12.4 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/82004

Actions #12

Updated by Mathias Brodala 8 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #13

Updated by Benni Mack 11 days ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF