Project

General

Profile

Actions

Bug #102144

closed

Cutting files in list view via dot menu not possible

Added by Kevin Appelt 10 months ago. Updated 14 days ago.

Status:
Closed
Priority:
Must have
Assignee:
Category:
Backend User Interface
Target version:
Start date:
2023-10-11
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
12
PHP Version:
Tags:
Complexity:
no-brainer
Is Regression:
Yes
Sprint Focus:

Description

Issue when cutting files in fileadmin in list view

Clipboard Normal (Copy elements is active) in List View
Copy file OK
Cut file NOT OK (Clipboard still uses "copy" elements and does not change to "move elements")

Clipboard Normal (Move elements is active) in List View
Copy file OK
Cut file NOT OK (Clipboard changes to "copy" elements)

Clipboard Normal (Copy elements is active) in Tiles View
Copy file OK
Cut file OK

Clipboard Normal (Move elements is active) in Tiles View
Copy file OK
Cut file OK

This is not a display bug - if i paste the file somewhere it gets copied (if I chose cut in list view!).
Looks like the cutting of files is broken in list view (but not in tile view)

This does only happen via the dot-menu in list view.
Right-click menu in list view is fine.
Tile view is fine.

v12 and main affected.

Actions #1

Updated by Gerrit Code Review 10 months ago

  • Status changed from In Progress to Under Review

Patch set 1 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/81412

Actions #2

Updated by Gerrit Code Review 9 months ago

Patch set 2 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/81412

Actions #3

Updated by Gerrit Code Review 9 months ago

Patch set 1 for branch 12.4 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/81432

Actions #4

Updated by Kevin Appelt 9 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #5

Updated by Benni Mack 14 days ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF