Project

General

Profile

Actions

Bug #103871

closed

Exception no. 1476107295 if no languageId can be found.

Added by Franz Holzinger about 2 months ago. Updated about 2 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2024-05-21
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
12
PHP Version:
8.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Routing Service.

After a small change in the sites.yaml file, the whole site is gone with this exception.

PHP Warning: Trying to access array offset on null in /path/typo3_src-12.4.15/typo3/sysext/core/Classes/Site/Entity/Site.php line 110

foreach ($configuration['languages'] as $languageConfiguration) {
    $languageUid = (int)$languageConfiguration['languageId'];


Files

Exception-Routing.html (45.1 KB) Exception-Routing.html Franz Holzinger, 2024-05-21 15:10
config-kurz.yaml (1.21 KB) config-kurz.yaml Franz Holzinger, 2024-05-22 10:44
Actions #1

Updated by Andreas Kienast about 2 months ago

  • Status changed from New to Needs Feedback

What exactly did you change in your configuration?

Actions #2

Updated by Franz Holzinger about 2 months ago

Here is the shortened config.yaml file.

Line 62-62:

    languageId: 3
routeEnhancers:

Then I tried this:

    languageId: 3
  -
routeEnhancers:

Then the website has gone. It did not help to undo this change.

Actions #3

Updated by Andreas Kienast about 2 months ago

Your attempted change results in invalid yaml. Did you clear all caches (var/cache/) after un-doing the change?

Actions #4

Updated by Franz Holzinger about 2 months ago

After this change it has not been possible to do anything. All the TYPO3 backend has gone because of this PHP error message.

Actions #5

Updated by Andreas Kienast about 2 months ago

Yes, please delete the cache manually from your filesystem.

Actions #6

Updated by Georg Ringer about 2 months ago

  • Status changed from Needs Feedback to Closed

I am closing this issue as it can be solved easily

Actions

Also available in: Atom PDF