Bug #11833

Sorting order of IRRE records is wrong after publishing

Added by Oliver Hader almost 9 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
Workspaces
Target version:
-
Start date:
2011-01-01
Due date:
% Done:

100%

TYPO3 Version:
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Imagine the following scenario:
  • existing page record with an IRRE field (use irre_tutorial to reproduce, there's also a test case for this)
  • one child record is existing in live workspace
  • add new child records in custom workspace
  • publish them

The result is, that the sorting order of those child records is wrong, since sorting is applied in t3lib_loadBDgroup->writeForeignField() which gets called when not all records have been processed. The solution is to recall writeForeignField() with a remapAction after all database operations.

forge_11833.patch View (2.93 KB) Oliver Hader, 2011-01-01 20:13

Associated revisions

Revision 1c6b07bc (diff)
Added by Oliver Hader almost 9 years ago

Fixed bug #11833: Sorting order of IRRE records is wrong after publishing

git-svn-id: https://svn.typo3.org/TYPO3v4/CoreProjects/workspaces/version/trunk@3627 743128fe-103e-dd11-99c4-001b210b3e58

History

#1 Updated by Oliver Hader almost 9 years ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 100

Fixed in r3627

#3 Updated by Michael Stucki almost 6 years ago

  • Category set to Workspaces

#4 Updated by Michael Stucki almost 6 years ago

  • Project changed from Workspaces & Versioning to TYPO3 Core
  • Category changed from Workspaces to Workspaces
  • Target version deleted (4.5 RC1)

#5 Updated by Benni Mack about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF