Bug #14557

EM: Updating an extension with changed dependencies blocks website

Added by Robert Lemke over 14 years ago. Updated almost 6 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Extension Manager
Target version:
-
Start date:
2005-02-17
Due date:
% Done:

0%

TYPO3 Version:
4.0
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

When updating an extension which has new dependencies to other extensions, the EM will replace the old extension with the new version but updated extension fails because of the unresolved dependencies.

Install an extension, add another extension to the dependency list and update the extension.

The extension manager should look into the emconf.php and evaluate the new dependencies before updating the extension.
(issue imported from #M809)

History

#1 Updated by Dmitry Dulepov almost 13 years ago

Set correct category for this bug (was empty)

#2 Updated by Alexander Opitz about 6 years ago

  • Status changed from New to Needs Feedback
  • Target version deleted (0)
  • PHP Version deleted (4)

Does this problem persist in a newer TYPO3 CMS (like 4.5 or 6.0)? The EM have been rewritten for both versions.

#3 Updated by Alexander Opitz almost 6 years ago

  • Status changed from Needs Feedback to Closed

No feedback for over 90 days.

Also available in: Atom PDF