Bug #14725

Shortcut to a timer-stopped page leads to a frontend error

Added by Rainer Kuhn over 14 years ago. Updated about 13 years ago.

Status:
Closed
Priority:
Should have
Category:
Frontend
Target version:
-
Start date:
2005-05-10
Due date:
% Done:

0%

TYPO3 Version:
3.8.0
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Reproducing:
Create a TS template to display a menu entry for every page.
Create two new pages:
  • Page1: Type "Standard", stopped by timer with a past date (in "General Options"/"Stop")
  • Page 2: Type "Shortcut", "Shortcut to page": Page1
    If you access Page2 by the menu link generated via the TS template (or if you access the page directly by URL), you'll get the frontend error message stated below.

I 'm not sure if this may be resolved by TYPO3 or if it is just a faulty operation of the BE user (in complex sites it may be hard to find out all shortcuts to a page that is going to be be stopped by timer later on).

Frontend error message:

Error!

The requested page didn't have a proper connection to the tree-root!

()
(issue imported from #M1066)

2005-10-19_bugfix_1066.patch View (1.32 KB) Administrator Admin, 2005-10-25 16:12

History

#1 Updated by Michael Scharkow about 14 years ago

This also happens if the page is hidden. So it is a more general problem if shortcut targets are unavailable. We have to throw an error message, but should we produce a 404 rather than this?

#2 Updated by Rainer Kuhn about 14 years ago

Personally I'd prefer a 404 as this would map the behaviour of static websites.
I don't know the relevant code parts of the core, but is there no possibility to get analogous functionality of other TYPO3 parts, e.g.
  • Links set in the BE to a TYPO3 target page by using <LINK targetpage>linktext</LINK> are not displayed as links if the target page is not available
  • generally if a requested page/URL is not available, TYPO3 jumps to the next available page of the upper hierarchy level
  • if page acess is limited to a FE group, a non-logged-in user is redirected to the login page
    Maybe one of these schemes could be transfered for the shortcut issue (just to describe the idea)?

#3 Updated by Sebastian Kurfuerst almost 14 years ago

i think if the page is not available, the shortcut to the page and the page itself shouldn't be visible in the menu, like it is when using the <link> tag.
All the other schemes might be strange for the end-user, because there is a broken link then, or the user is forwarded to another page, which might cause confusion.
Greets,Sebastian

#4 Updated by Rainer Kuhn almost 14 years ago

I would suggest the same solution as Sebastian has proposed.

#5 Updated by Sebastian Kurfuerst almost 14 years ago

the patch implements my suggestion. greets, sebastian

#6 Updated by Sebastian Kurfuerst almost 14 years ago

fixed in CVS.

Also available in: Atom PDF