Bug #14788

tslib_cObj::imageLinkWrap not passing information if image.imageLinkWrap.JSwindow.altUrl set

Added by Peter Russ over 14 years ago. Updated about 13 years ago.

Status:
Closed
Priority:
Should have
Category:
Frontend
Target version:
-
Start date:
2005-06-02
Due date:
% Done:

0%

TYPO3 Version:
3.8.0
PHP Version:
4
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

providing a different url to replace showpic.php by TS
image.imageLinkWrap.JSwindow.altUrl=typo3conf/ext/fdfx_showpic/showpic.php
doesn't pass any information on image file, additional params etc, i.e.

before (w/o .altUrl): e.g. openPic('showpic.php?imglist=uploads%2Fpics%2F2113_10.jpg%7Cupload...',...

after (w .altUrl as mentioned above): e.g. openPic('typo3conf/ext/fdfx_showpic/showpic.php',...

This behavoir can be found to ALL versions of Typo3.

(issue imported from #M1153)

class.tslib_content.php.patch View (886 Bytes) Administrator Admin, 2005-06-02 13:04

bug_1153_post.diff View (733 Bytes) Administrator Admin, 2006-04-17 16:45

History

#1 Updated by Peter Russ over 14 years ago

to test just try:
image.imageLinkWrap.JSwindow.altUrl=showpic.php

which is replacing showpic.php by itself.

#2 Updated by Michael Stucki over 13 years ago

Fixed in CVS.

#3 Updated by Stanislas Rolland over 13 years ago

This change prevents postprocessing of showpic parameters and recalculation of the md5 parameter, since the value calculated in tslib_cObj is appended to the url.

I think that if this altUrl feature is used, it should be up to the script using it to add any required parameters using postUserFunc.

I would propose to revert this change.

#4 Updated by Michael Stucki over 13 years ago

I will have a look at it...

#5 Updated by Michael Stucki over 13 years ago

Sorry, it took a little longer to get back to this. Attached is a patch that adds a new property which can be used to disable the addition of the parameters. Thanks to Dirk Hoffmann.

#6 Updated by Michael Stucki about 13 years ago

Fixed in 4.0.1 and 4.1-dev. You can now set a new TypoScript property "JSwindow.altUrl_noDefaultParams" which skips adding of these parameters.

Also available in: Atom PDF