Bug #14836

Session-Lifetime for BE-User and FE-User doesnt work in FE

Added by old_heldenschreck almost 17 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Should have
Category:
Frontend
Target version:
-
Start date:
2005-06-22
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
3.8.0
PHP Version:
4
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

The new Lifetime/SessionTimeout for FE-User and BE-User doesnt work in Frontend (as it does in the Backend).

There are missing the following lines in the Source (possible fix):

/index.php (BE-User Initialisation):
$BE_USER->auth_timeout_field = intval($TYPO3_CONF_VARS['BE']['sessionTimeout']);

/tslib/class.tslib_fe.php (function initFEuser):
$this->fe_user->auth_timeout_field = intval($this->TYPO3_CONF_VARS['FE']['lifetime']);

(issue imported from #M1233)


Related issues

Related to TYPO3 Core - Bug #17666: be sessions time out before $TYPO3_CONF_VARS["BE"]["sessionTimeout"]Closed2007-10-10

Actions
Related to TYPO3 Core - Bug #19153: Insonsistent description/initialisation of class.t3lib_beuserauth.php->auth_timeout_fieldClosed2008-07-25

Actions
Related to TYPO3 Core - Bug #59365: Session Lifetime for FE-Users can not be less than 6000 secsClosed2014-06-05

Actions
#1

Updated by Franz Holzinger over 16 years ago

With the latest CVS Core from 19.1.2006 I get a timeout after 1 or 2 minutes from the backend.
However I have set it to
[BE][sessionTimeout] = 12000

#2

Updated by Christian Kuhn over 12 years ago

Fixed, unable to reproduce in recent versions:

This definatly works in 4.2.8:

The proposed fix in tslib_fe is actually in class tslib_feUserAuth, method start:
$this->auth_timeout_field = $this->lifetime;

#3

Updated by Benni Mack over 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF