Bug #14955

Some TCAdefaults work only with "Page (inside)" and not with the Wizard

Added by old_MarkusWagner almost 16 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2005-09-03
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
4.6
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

While creating a new page, I tried to set TCAdefaults.pages.hidden=1 or TCAdefaults.pages.doktype=2 which only works when working without the Wizard (Button "Page(inside)").
The problem does not occur with TCAdefaults.pages.title=test for example, this works with both.

(issue imported from #M1428)


Files

0001428.tar.gz (174 KB) 0001428.tar.gz Administrator Admin, 2005-12-29 18:43
tsconfig_vs_useColumnsForDefaultValues.diff (653 Bytes) tsconfig_vs_useColumnsForDefaultValues.diff Administrator Admin, 2008-08-25 18:47

Related issues

Has duplicate TYPO3 Core - Bug #16643: TCAdefaults.pages.hidden=1 doesn't always hide pagesClosedChristian Kuhn2006-10-14

Actions
#1

Updated by Sebastian Kurfuerst over 15 years ago

Hi,
can you please make a screenshot to clarify this?
Thank you, Sebastian

#2

Updated by old_MarkusWagner over 15 years ago

Hi Sebastian! Sorry for being late, I had no time for it until now. Made 2 screenshots to show the problems (zipped), had configuration "TCAdefaults.pages.hidden=1" and "TCAdefaults.pages.doktype=2" in User TSConfig.
This configuration only works when working without the wizard (pic 1), with the wizard it seems that the configuration doesn't work (pic 2). It is funny that this all does not happen when using the wizard to add a page UNDER the currently selected page (looks like pic 1).
I used a fresh 3.8 install to test it.

#3

Updated by Jesus Hormigo over 15 years ago

After trying over a 3.8.1 over an empty installation with 1 page created and with the following TSConfig:

TCAdefaults.pages.hidden = 1
TCAdefaults.pages.doktype = 2

I tested that works perfectly well when creating it with the wizard or creating it with Page (inside).

I evaluated the pictures you sent and I noticed that the error you noticed is because you point where you try to create the PIC2.jpg page is underneath the page and NOT inside. So you can observe it'll sit on / and not under /root/ page you created and therefor is not affected by any TSConfig.

#4

Updated by Sebastian Kurfuerst over 15 years ago

Hi,
I close the bug for now. If there is more information, please re-open the bug.

Thanks, Greets, Sebastian

#5

Updated by old_MarkusWagner over 15 years ago

@Jesus:
I think I understand what point you are taking me to, but I don't think you're right.
User TSConfig (!!) should ALWAYS affect ANY site, no matter if it is under or on a specific site.

#6

Updated by Sebastian Kurfuerst over 15 years ago

It might be that the problem just exists when the new page is in the root level.. Just a guess.

Greets, Sebastian

#7

Updated by Jesus Hormigo over 15 years ago

I confirm that this don't happens on a PAGE TSCONFIG level but IT HAPPENS on a USER TSCONFIG level.

Markus thanks for the clarification specifying it was at USER TSCONFIG level (sorry for not read it properly in your comment 29.12.05 18:42). It only happens when adding the page at a root level, if you add it inside a root level page works for Page inside and wizard.

#8

Updated by old_MarkusWagner over 15 years ago

I can also confirm this: it only happens when adding a page to the rootlevel with the wizard.

#9

Updated by Ernesto Baschny over 15 years ago

Hi,

This only happens if you choose to place the new page "AFTER" some existing page, no matter which level you are. Placing the page right on top of the presented page tree or as the first page INSIDE some other page the problem doesn't appear.

The problem is: the defaults set in TCEdefaults conflict with the "ctrl.useColumnsForDefaultValues" setting in TCA for the pages table (which is "doktype,fe_group,hidden" by default). This setting tells TYPO3 to use the values from the previous peer page for these fields in the newly created page.

So this might be considered a bug if you want TCEdefaults to override any other setting (even useColumnsForDefaultValues). In that case, the fix would be to reverse the "Default values as set in userTS:" and "Fetch default values if a previous record exists" parts in class.t3lib_transferdata.php, method fetchRecord().

In my opinion they should be reversed, as the expected behaviour is exactly that one: TCEdefaults override any other setting, even TCA.

#10

Updated by Benni Mack over 14 years ago

This bug still exists in 4.0.4 and it is a bug as long as it behaves different when clicking on "New page inside" and "New page after".

#11

Updated by Marc Wöhlken almost 13 years ago

This bug is still present in TYPO3 version 4.2.1

#12

Updated by Steffen Kamper almost 13 years ago

Thanks Ernesto for this very good description of the problem.
With this i was able to write a patch in short time.

Please test it and confirm.

What i did? After reading the useColumnsForDefaultValues i look if a value is set befor by TSconfig and only use the value if it's not. So TS overrides useColumnsForDefaultValues in any case.

vg Steffen

#13

Updated by Noel Bossart over 10 years ago

The Bug is still present in 4.4.7 dev

#14

Updated by Sebastian Kurfuerst about 10 years ago

  • Status changed from Accepted to New
  • Assignee deleted (Sebastian Kurfuerst)
  • Target version deleted (0)
  • TYPO3 Version changed from 3.8.0 to 4.6
  • PHP Version deleted (4)
#15

Updated by Gerrit Code Review about 8 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/20900

#16

Updated by Gerrit Code Review about 8 years ago

Patch set 1 for branch TYPO3_6-1 has been pushed to the review server.
It is available at https://review.typo3.org/21065

#17

Updated by Gerrit Code Review about 8 years ago

Patch set 1 for branch TYPO3_6-0 has been pushed to the review server.
It is available at https://review.typo3.org/21067

#18

Updated by Gerrit Code Review about 8 years ago

Patch set 1 for branch TYPO3_4-7 has been pushed to the review server.
It is available at https://review.typo3.org/21068

#19

Updated by Gerrit Code Review about 8 years ago

Patch set 1 for branch TYPO3_4-5 has been pushed to the review server.
It is available at https://review.typo3.org/21069

#20

Updated by Wouter Wolters about 8 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#21

Updated by Benni Mack over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF