Bug #15146

Login sometimes fails with reverse proxy load balancer (pound)

Added by old_shanson about 12 years ago. Updated almost 7 years ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
-
Start date:
2005-10-21
Due date:
% Done:

0%

TYPO3 Version:
3.8.0
PHP Version:
5
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

We found that logins to the backend would sometimes fail on our production system, which runs on multiple web servers behind a pound reverse proxy load balancer. (http://apsis.ch/pound). The load balancer distributes requests randomly among the web servers.

Through trial and error we found that the failure occurs only when multiple web servers are configured in the web balancer, and the POST for the form is sent to a different web server than the GET.

The workaround is to configure pound with 'Session IP ...' so that all requests from a client IP are sent to the same web server.

The problem doesn't occur in our sites with Typo3 3.7.0.
(issue imported from #M1716)

History

#1 Updated by Christian Boltz about 12 years ago

I don't think #15146 and #15146 are related.
Yes, they both talk about reverse proxies, but
- #15146 is about load balancing and seems to be related to a sesion problem IMHO
- #15146 is about wrongly generated URLs because of different paths in server's / browser's point of view
These are two completely different things ;-)

#2 Updated by Christian Kuhn almost 7 years ago

Resolved, no change required.

Also available in: Atom PDF